Nyerguds

1.06c development topic

768 posts in this topic

Nyerguds    73

Well, that is true, actually. The Covert Ops does feature some of the normally multiplayer-only units, like the Nod SSM and the Chem Warriors. You can't actually build them anywhere, though, and those units have always been in the game.

 

At least one of the Nod missions also gives you helipads, and while you can't actually build more helipads, this does allow you to build (more of) the normally-inaccessible Apache Helicopter. Though you can build those after capturing a GDI Construction Yard anyway, so it's not quite as "exclusive" a unit as, say, the Chem Warrior.

Share this post


Link to post
Share on other sites
Superole    0

Hello (again cnc-)World! ;)

 

First off: Thank you Nyerguds, for taking the time to help your fellow retro-gamers! :thumbsup:

 

I am however slightly confused by the versioning of this patch.

-Is the current release the version 1.06c revision 3 update 2?

...and when was this released? (I've seen different dates including 2010, 2012, and 2014 all mentioning 1.06c r3)

 

The first post in this thread mentions things that will be (or already are?) fixed in the revision 4.

-Do you have any plan for a release of this?

-Is there possibly some kind of "nightly build" available somewhere, that includes these fixes?

 

Thank you in advance for enlightening me on this.

 

 

Best Regards

Superole

Share this post


Link to post
Share on other sites
Nyerguds    73

Hello (again cnc-)World! ;)

You're making me nostalic; the "C&C World" fan site went defunct years ago :(

 

First off: Thank you Nyerguds, for taking the time to help your fellow retro-gamers! :thumbsup:

 

I am however slightly confused by the versioning of this patch.

-Is the current release the version 1.06c revision 3 update 2?

...and when was this released? (I've seen different dates including 2010, 2012, and 2014 all mentioning 1.06c r3)

The official site has the simple answer to that:

http://nyerguds.arsaneus-design.com/cnc95upd/cc95p106/

It says "(Current version: 1.06c revision 3 - July 8, 2014)"

 

On to the more complete answer: the current version of the patch (1.06c revision 3) was released years ago, but I had to add some small fixes to the installer and the game configuration tool to account for some annoying changes they had made in the game and compatibility settings in The Ultimate Collection release of the game. Hence the release date confusion, and the "update 2" thing. Since these are all peripheral changes, though, the actual game version never changed; the game main menu will still just say "v1.06c r3". The details of this update are described in the ModDB news post:

http://www.moddb.com/mods/command-conquer-unofficial-patch-106/news/video-packs-and-small-updates

 

So, yeah, you're better off making sure you get it from the official download sources to be sure it has those fixes.

 

The first post in this thread mentions things that will be (or already are?) fixed in the revision 4.

-Do you have any plan for a release of this?

-Is there possibly some kind of "nightly build" available somewhere, that includes these fixes?

It's... kind of a tricky issue. Truth is, the internals of the patch are a mess. The people over at the CnCNet project had devised an interesting auto-patching system, and the patch project has become too unmanageable to continue it without that, really. The problem is that a lot of smaller fixes are just hex edits I've done straight into the game's exe file, often without documenting them sufficiently for myself. Switching to the new system requires me to have all my changes in code files to be applied to the original clean exe, but that means I first have to reverse engineer my own patched exe file just to get all the changes out.

 

Long story short... I'm very sorry, but I haven't had the time or motivation to do it. I generally function on bursts of interest, and I've sadly seen how the C&C1 community pretty much dies whenever my interest drifts to other things. It's kind of scary, to be honest, to be a single person keeping a game alive.

 

So, yeah. I don't know. Maybe one day I'll get excited about patching C&C1 again. Maybe the cncnet people will completely reverse engineer the engine to C++ code before I get the chance to. I don't know; they're doing some crazy stuff there. I wish I could help you, but I wasn't kidding when I said the project internals are a mess; there are a bunch of undocumented incomplete experiments in it that I should really either finish or remove, so despite some nice changes that were completed, the exe I have right now is absolutely unfit for publication even as beta.

 

The cncnet people were less concerned about the incomplete nature of said changes, though. The exe they use for multiplayer has expanded sidebar, mouse wheel scrolling on the sidebar, and configurable hotkey support, though the handling of that sidebar expanding has some bugs in its scrolling logic I found unacceptable for publication; one of my main philosophies behind this patch is that any extra is extra, and when played in 100% original settings, the game should react 100% like the original. I'm not sure if the exe they use for multiplayer can actually be used for single player, though.

Share this post


Link to post
Share on other sites

In case it's of any help or possible to fix at some point, I'm getting a crash in the commando mission ("Use a GDI commando to infiltrate the NOD base, **** ** destroy the ******** so that the base is incapacitated."). It happens either when playing or after sitting idle at the menu (if I need to leave).

In case it changes anything, this is the version provided by Origin as part of the "Command and Conquer The Ultimate Collection" which uses an online code and is distributed through the Origin QT app. I have the patch v1.06c r3 installed with DDraw. If you need more details (the exact contents of an ini file, for example), just ask.

For what it's worth, I "made do" with regular saves, since the crash seemed time based rather than anything else.

Faulting application name: C&C95.exe, version: 1.6.3.3, time stamp: 0x32dd83d5
Faulting module name: USER32.dll, version: 6.1.7601.17514, time stamp: 0x4ce7ba59
Exception code: 0xc0000005
Fault offset: 0x00025f79
Faulting process id: 0xd8c8
Faulting application start time: 0x01d101e4f77c60a2
Faulting application path: C:\Program Files (x86)\Origin Games\CNC and The Covert Operations\C&C95.exe
Faulting module path: C:\Windows\syswow64\USER32.dll
Report Id: 48811762-6e3e-11e5-806d-782bcb959d5b

Share this post


Link to post
Share on other sites
Nyerguds    73

Too bad none of that debug info is useful since it doesn't actually give any internal addressing of C&C95 itself.

 

One thing you can do is check if compatibility mode for Windows 95 is enabled on C&C95.exe. If I remember correctly, the configuration tool tends to disable that when cnc-ddraw is enabled, because on WinXP it ran better that way, but it seems that on newer OSes it's better to enable it anyway, even with cnc-ddraw.

 

So do keep in mind, anything you do in the configuration tool will most likely disable the compatibility mode again, so if you ever use it again you'll need to re-enable the compatibility mode manually afterwards.

Share this post


Link to post
Share on other sites

Hi I've recently buyed the Ultimate Colection, and I was playing good old C&C95, then I found out about this patch and I like it very much, but now scroll speed is way too fast, even with the lowest settings.

 

I'm using the latest patch 1.06 r3. How do I solve this?

Edited by Michele Boncristiano

Share this post


Link to post
Share on other sites
Nyerguds    73

Launch the CCConfig tool that's located in the game folder. There is an option "limit frame rate", somewhere in the bottom right of the first tab. This should fix the fast scroll bug.

Share this post


Link to post
Share on other sites
talbin    0

Edit: I just played GDI mission 9 and when you blow up the turrets three of your gunboats come on screen. For some reason, none of them fire. Their turrets turn towards an enemy but they never fire. I'm guessing this wasn't intended by the game because the video cut scene after the mission shows them firing and blowing up turrets. They just voluntarily let the obelisk kill them without firing back.

Edited by talbin

Share this post


Link to post
Share on other sites
talbin    0

Found another one. After beating mission 10 on your way to mission 11 in greece the arros don't show up for which country you need to click on. I had to click all over the map to figure out where I needed to go.

Share this post


Link to post
Share on other sites

Edit: I just played GDI mission 9 and when you blow up the turrets three of your gunboats come on screen. For some reason, none of them fire. Their turrets turn towards an enemy but they never fire. I'm guessing this wasn't intended by the game because the video cut scene after the mission shows them firing and blowing up turrets. They just voluntarily let the obelisk kill them without firing back.

this is how it's supposed to be. yeah, I have tryed to save em too

Share this post


Link to post
Share on other sites
Nyerguds    73

Edit: I just played GDI mission 9 and when you blow up the turrets three of your gunboats come on screen. For some reason, none of them fire. Their turrets turn towards an enemy but they never fire. I'm guessing this wasn't intended by the game because the video cut scene after the mission shows them firing and blowing up turrets. They just voluntarily let the obelisk kill them without firing back.

As MilkeyWilkey said, that's normal and completely intended. These gunboats exist only as cannon fodder to show the might of the Obelisk. Experiments in mission making have shown that any gunboat that isn't on the map from the start but instead gets reinforced from the map edge later will be unable to use its weapons.

 

In fact, because of this mission, there's another special logic in the game, which makes gunboats die from a single Obelisk shot. This is actually pretty handy on some of the later Nod missions.

Found another one. After beating mission 10 on your way to mission 11 in greece the arros don't show up for which country you need to click on. I had to click all over the map to figure out where I needed to go.

There's a single arrow coming up from the bottom. It's not very visible, but the animation should show you where it is.

Share this post


Link to post
Share on other sites
talbin    0

Looks like the mission 10 to 11 bug was just a one time anomaly. I couldn't reproduce it. Gotta love that stuff. In other news, I played all the way through NOD again and didn't run into anything strange. Great job with the updated patch!

Share this post


Link to post
Share on other sites

I was messing around with C&C today, and was getting quite annoyed by the crackling audio that happens when my HD Music Pack is being used.  So, I decided to investigate and discovered something interesting.  As soon as I turned off "limit frame rate" in CCConfig, most of the crackling went away!  This caused me to investigate further, because the screen now scrolled too fast in-game.  So, I started to look at Red Alert, which rarely gets any crackling audio using my Red Alert HD Music Pack.  What I discovered was that Red Alert is capped at 120fps, while C&C is a mystery (I'm guessing 60fps, since it does not say?)  So, I decided to disable "limit frame rate", but went in to my Nvidia settings, and manually set the frame rate to be limited at 120fps.  This completely worked!  Now my screen scrolls at a decent speed in-game (in fact, a bit faster than before, which I felt was too slow) - AND most of the audio crackling is gone! 

 

In case anyone wants to solve the audio crackling with the HD Music Pack, or if someone simply wants the screen to scroll faster (but not too fast), this solution is definitely for you.

Share this post


Link to post
Share on other sites
Nyerguds    73

It's a setting in ddraw.ini. You can just edit it in there.

I set it to 60 fps because that's the advertised frame rate on the game box. I guess I could make it a setting in the tool, but I kept it as one simple option for simplicity's sake.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now