Violetnred

script error while importing W3X into 3DS Max

10 posts in this topic

tried to export two w3x packs (extracted from .manifext packs) using two different versions of the importer plugin, getting the same results: cannot select multiple files, some files refuses to be imported and simply reopens fiel select window and the rest of them makes the scrip report an error about array size being 0.

 

tried to search for a solution, but didn't find anything at all and i don't know what to do now.

 

also, if there's a pack of 3DS Max or blender ready models, i'll be happy to have that instead of the solution to this problem.

 

thanks in advance for any possible help :)

0

Share this post


Link to post
Share on other sites

are you using the w3d xml asset importer from bibber's website for 3D Studio Max 9? That's the one that worked for me. You don't import multiple files. It's one at a time.

0

Share this post


Link to post
Share on other sites

are you using the w3d xml asset importer from bibber's website for 3D Studio Max 9?

yes and other stuff from the same site.

 

here is what i'm doing:

extracting whole StaticStream.big from Kane's Wrath installation directory / Core / 1.0 with BIG Extractor

opening static_common.manifest with Asset Extractor

extracting all files as Sources for specific unit (say, ABBHIVE) from each category (Texture, Animation, CollisionBox, Container, Hierarchy and Mesh)

going to 3DS Max, Running the scrip, then going to Utilities, selecting appropriate maxscript, selecting texture directory (where i put extracted textures), then i don't really know what to do.

 

clicking Import Hierarchical Model on _HRC or other files either does nothing or gives:

-Type error:Call needs function or class, got: undefined" on the string

"wwSetExportBoneFlag maxPivots[maxPivots.count] true"

Import Skeleton does pretty much the same.

clicking on Import Simple Mesh imports meshes (files as ABBHIVE.ABBHIVEA or ABBHIVEDR_SKN.ABBHIVEB), but with the same error, without textures and they are sitting at 0,0,0 while some pieces must be sitting somewhere else.

0

Share this post


Link to post
Share on other sites

You need a tool to combine the extracted parts back to a normal w3x model before importing them.

0

Share this post


Link to post
Share on other sites

You need a tool to combine the extracted parts back to a normal w3x model before importing them.

thanks for the tip, but where do i get it?

0

Share this post


Link to post
Share on other sites

tried putting all w3x of specific unit together, i get nothing on the first try of importing the fiel and scrip error on the second.

 

do i need to combine them in specific order? should i combine ALL .w3x files describing specific model? should i make any changes in the resulting file?

0

Share this post


Link to post
Share on other sites

I got that tool, but it doesn't seem to work for me, I don't know how to do it with text editor either, Would somebody help please?

 

I want to merge GDI Rig together and use it's model, But it's more complex than i thought.

EDIT: As for not working, I did according to the instructions (Dragging the folder, using CMD), i always get an error. I don't have problems with max and SDK tho.

Edited by M.P
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now