Jump to content

RussianCommunistBear

Members
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About RussianCommunistBear

  • Rank
    Recruit
  1. RussianCommunistBear

    Lags in RA2 and YR, known solutions doesn't works

    Checked my game speed, it was set on medium. I also noticed that the slower the game speed, the more laggy it gets. However, performance peaks at faster speed (its actually feels pretty smooth, but i tested it only with a few units and without any effects on screen and i don't like game being so fast), fastest seems more laggy.
  2. RussianCommunistBear

    Lags in RA2 and YR, known solutions doesn't works

    I tried to run the game as administrator with Aero and visual themes disabled and Windows XP SP3, XP SP2, 98, 2000 and Vista compatibility modes. They all doesn't make any difference.
  3. Recently i'm installed The First Decade from my old disk and spend some time patching it (i installed both official patches and unofficial 1.03 patch) and getting all games to work properly. I manage to solve issues in all games except for Red Alert 2 and Yuri's Revenge expansion: both games are working but i experience lags ingame even when there is almost nothing happening on screen. My PC specs: Windows 7 64-bit Intel Core i5-4690K 3.50 GHz (with turbo boost up to 3.90 GHz) Nvidia GeForce GTX 960 2GB 8 GB RAM List of things i tried to do: 1. Installed this graphics patch - it solved similar issue in Tiberian Sun, but doesn't worked for RA2 2. Added VideoBackBuffer=no to game configs - no effect 3. Tried ddraw.dll patch - caused black screen when i launch the game 4. Tried "Disable Hardware Acceleration" option form this unofficial patch launcher - turns out it uses same ddraw.dll i mentioned above, with same effect 5,6. Tried to disable hardware acceleration using register edit and DirectX SDK - looks like technically its does same thing that ddraw.dll does, caused black screen too 7. Tried DDWrapper with ForceDirectDrawEmulation and NoVideoMemory options set to 1 - no effect (also enabling only one of these options causes black screen) 8. Tried different compatibility modes and windowed mode - no effect I can't find any more solutions, i don't know what else i can do. Any other ideas how to solve my problem? P. S. Sorry if i misspelled something, i'm not a native english speaker
×