Jump to content
Sign in to follow this  

insert correct CD-Rom 'Generals' glitch

Recommended Posts

Hi all


just built my nice new system with vista 64 installed and the first thing i go to play isnt working!


im getting a message 'insert correct CD-Rom' when i try to play Generals + zero hour

iv tried all CDs

iv updated to the latest versions

iv tried running it as a 'win xp'


nothing has worked


anyone know how to fix this problem?

Share this post

Link to post

From what I've read about this error it mostly appears when your using and illegal copy of the game. Its the copy protection kicking in.


If your copy of the game is legal, it could be something to do with you using Vista 64.

Share this post

Link to post

I don't think 64-bit operating systems and games play nice together. Then again, try running as Administrator. That's the first thing to try.

Share this post

Link to post

got it working but im not sure what fixed it..


i downloaded some optional vista updates and went on to the samsung website and found a driver for my dvd-rw.. after that it worked fine without me changing any of the settings on the shortcut.


- - - -


well i say its working - silly me put the graphics up too high and its not supported by my TV.. now i just get a black screen and i cant see to change the settings..


any ideas?


strangly iv tried re-installing to a new directory but my faulty settings are still there..


is there a safemode or any way i can manually change the graphics settings without running the game?

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.