Jump to content
Johnnyxp64

How To Play Generals / Zero Hour In Windows 7 X64

Recommended Posts

Updated: 23-01-2012

Recently (12 August 2009) I installed from TFD, Generals Zero hour for some old good fights after i saw in you tube the Generals Trailer 1 at E3 that made me wanna revisit that game.

Now i am running Windows 7 x64 and after installation the program didn't run.

so here is what you should do to make it run

  • Make sure you have the latest Direct-X 9.0c installed, you can Google it or get it from Microsoft
  • make sure you have windows 7 service pack 1 at least installed!
  • make sure you have the LATEST Graphic Drivers installed for your VGA Card and that meets the game's requirements!
  • make sure that both Generals and Zero hour its on its latest patch version! TFD should be updated!
    (must be a clean installation no other MODS etc!)
  • into your "user" directory (named with your user account yeah you know there where you see the folder my pictures, my music etc)
  • in there go to "My Documents"
  • well there after trying to run the game you would see a Command and Conquer Generals Zero Hour Data folder.
  • open it.
  • right click and create a new empty .TXT file and rename it options.ini
    (make sure you see the extension .txt and you don't end up having a stupid file named options.ini.txt!) if you dont know how to see the files extension in windows 7, Google it or get an Xbox to play :P
  • now copy the following lines inside and Save it!

**warning in the resolution section put your resolution*********
***also some LOD settings may not work with your VGA card! remove those lines if you cant run the game!****

AntiAliasing = 1
BuildingOcclusion = yes
CampaignDifficulty = 0
DynamicLOD = yes
ExtraAnimations = yes
GameSpyIPAddress = 0.0.0.0
Gamma = 50
HeatEffects = yes
IPAddress = 0.0.0.0
IdealStaticGameLOD = Low
LanguageFilter = false
MaxParticleCount = 5000
MusicVolume = 55
Resolution = 1366 768
Retaliation = yes
SFX3DVolume = 79
SFXVolume = 71
ScrollFactor = 60
SendDelay = no
ShowSoftWaterEdge = yes
ShowTrees = yes
StaticGameLOD = Custom
TextureReduction = 0
UseAlternateMouse = yes
UseCloudMap = yes
UseDoubleClickAttackMove = no
UseLightMap = yes
UseShadowDecals = yes
UseShadowVolumes = yes
VoiceVolume = 70
  • then Right Click on your Generals / Zero Hour shortcut (if you don't have make one), in Widows 7 most games make there shortcuts into the "GAMES" menu in Start Menu
  • and in the Compatibility Tab just select Windows XP SP3 and click "Run as administrator" option too (if you are not an admin)
  • that's it go inside change your settings and restart the game.

other alternative simpler solution:

  • windows 7 x64 SP1 (service pack1 is crucial!)
  • clean install of the game and patch to latest versions!
  • change compatibility of the main .exe to Windows XP sp3 (so that the main menu shellmap works ok)
  • run the game for 1st time and during this run go to setting and change everything you want! (besides resolution)
  • then exit game and locate the options.ini i told you before in your Documents\Generals Zero Hour data\ folder
  • change there only the resolution line to your screen's native. (ex Resolution = 1366 768)
  • save and rerun the game. you are done!

Have fun that's an order!

  • Upvote 1

Share this post


Link to post
Share on other sites

i've tried for the last hour to get c&c generals zh to work on my newly installed win7 x64 ultimate machine. i've tried creating the options.ini file in both generals and zh folders in my documents. i also set compatibility mode to windows xp (sp3)... i tried a bunch of other modes as well. and i am the admin but i set run as admin anyways. when you load the game the disc spins, the slash screen comes up and then the application doesn't respond and hangs indefinitely. any solutions or ideas would be appreciated

Share this post


Link to post
Share on other sites

I too am having the same problem. Just got my computer with windows 7 ultimate and followed the steps above. I still get the title screen and then it doesn't load. Please help! I can/will donate through paypal if someone can come up with a fix.

 

Here is crash info:

Release Crash at Fri Feb 05 18:02:31 2010
; Reason Uncaught Exception during initialization.

Last error:
Exception is access violation
WinMain at 401700
Error code: EXCEPTION_ACCESS_VIOLATION
Description: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Access address:06CAF000 was written to.

Stack Dump:
  <Unknown>(-1) : <Unknown> 0x007D1A0F

Details:
Register dump...
Eip:007D1A0F    Esp:0018AF90    Ebp:0001D1F7
Eax:06CAF000    Ebx:00000064    Ecx:FFFE21D4
Edx:0000002B    Esi:06CAED84    Edi:06C90F58
EFlags:00010206 
CS:0023  SS:002b  DS:002b  ES:002b  FS:0053  GS:002b
EIP bytes dump...

Bytes at CS:EIP (007D1A0F)  : 89 28 83 C0 04 4A 75 F5 4B 75 E9 5F 5E 5D 5B C3 90 B8 B4 4F 00 00 E8 36 EF 10 00 56 8B B4 24 BC

Share this post


Link to post
Share on other sites
Recently i installed from TFD, Generals Zero hour for some old good fights after i saw in you tube the Generals Trailer 1 at E3 that made me wanna revisit that game.

 

Now i am running Windows 7 x64 and after installation the program didnt run.

 

so here is what you should do to make it run

  • Make sure you have the latest DirectX 9.0c installed, you can Google it or get it from Microsoft
  • into your "user" directory (named with your user account yeah you know there where you see the folder my pictures, my music etc)
  • in there go to "My Documents"
  • well there after trying to run the game you would see a Command and Conquer Generals Zero Hour Data folder.
  • open it.
  • right click and creat new empty .TXT file and rename it options.ini
  • copy those lines inside and Save it!
**warning in the resolution section put your resolution*********

 

AntiAliasing = 2
BuildingOcclusion = yes
CampaignDifficulty = 0
DrawScrollAnchor = yes
DynamicLOD = no
ExtraAnimations = yes
GameSpyIPAddress = 0.0.0.0
Gamma = 50
HeatEffects = yes
IPAddress = 0.0.0.0
IdealStaticGameLOD = Low
LanguageFilter = false
MaxParticleCount = 5000
MoveScrollAnchor = 
MusicVolume = 50
Resolution = 1440 900
Retaliation = yes
SFX3DVolume = 72
SFXVolume = 64
ScrollFactor = 145
SendDelay = no
ShowSof****erEdge = yes
ShowTrees = yes
StaticGameLOD = Custom
TextureReduction = 0
UseAlternateMouse = yes
UseCloudMap = yes
UseDoubleClickAttackMove = no
UseLightMap = yes
UseShadowDecals = yes
UseShadowVolumes = yes
VoiceVolume = 78

 

  • then Right Click on your Generals / Zero hour Sortcut (if you dont have make one), in widows 7 most games make there sortcuts into the "GAMES" menu in Start Menu :huh:
  • and in the Compatibility Tab just select Windows XP sp3 and click "Run as administrator" option too (if you are not an admin)
  • thats it go inside change your settings and restart the game.

have fun thats an order! :lol:

 

 

 

 

Hi I followed the above instructions and still had no luck. I load the game up and it hangs indefinately. any suggestions would be appreciated

Share this post


Link to post
Share on other sites

Hi

I'm in the same boat with C&C generals and in fact with generals its self . I have it working thanks to the posts but I have a problem with the game moving on.

After playing a level it just asks me to play again or quit.

I have done all the mods mentioned here but no joy getting it to move on.

I have win 7 64 home, amd x4 955, 4gb ram, nvidia gtx 260.

I'm running the program in xp mode and as admin.

Just to add the problems if a go to CHALLENGE as soon as game starts for real with bulldozers etc. the whole thing blows up and says i have been defeated.

 

Have any guru got any idea what I can do to get these programs running?

 

 

Share this post


Link to post
Share on other sites

I just spent some time reviewing this problem. I'm running windows 7 home edition as well

 

All you need in the .ini file is the IdealStaticLOD line and the StaticGameLOD line. In fact, if you include all the lines from the post above, you are more likely to end up with an error.

 

Way to make this thing work on an operating system that tries (unfortunately, cause i kinda like win7) to fight you the whole way:

 

1. Add a Maps folder and the Options.ini file to ...\My Documents\Command & Conquer Generals (Zero Hour) Data\

2. Install DirectX 9.0c from Microsoft.com

3. Disable UAC (User Account Control - Generals/Zero Hour are most likely not compatible with UAC)

4. Right click on generals.exe (this works on both) and click the compatibility tab

5. Check all of the following:

1. Run in compatibility mode (i ran it in WinXP w/SP3)

2. Run as Administrator

3. Disable Visual Styles (this disables the aero style of the Vista virus and win7).

6. Save the changes and attempt to run the .exe

 

If they dont run, post back and ill try to figure out what i might have left out.

 

Share this post


Link to post
Share on other sites

Thank you rtsking117

 

Did exactly as you said & the game is runing right now on Windows 7 x64 perfectly. Am off to get that Global Crisis Mod also, it sounds like fun. My disabled son & I play Zero Hour all the time.

 

IMHO

iseppiq B)

Share this post


Link to post
Share on other sites

After nine hours of trying to figure this out I simply had to put the .ini file in this folder. You will also see the Zero Hour Data folder too. Copy the same .ini file in there too.

C:\Users\**Your Name Of Computer**\Documents\Command and Conquer Generals Data

 

Let me know if this helps people.

Edited by 94civiccx

Share this post


Link to post
Share on other sites
After nine hours of trying to figure this out I simply had to put the .ini file in this folder. You will also see the Zero Hour Data folder too. Copy the same .ini file in there too.

C:\Users\**Your Name Of Computer**\Documents\Command and Conquer Generals Data

 

Let me know if this helps people.

Im having troubles to understand your above post unfortunately,

first of all you do reefer to "options.INF" you to also? :thumbsup:

Copy the same .ini file in there too.
In there? in my view you talk about the "documents library/generals data folder"

and you suggest that i shall copy it to "documents library/generals data folder" were it already lies? :)

 

My problem is that generals minimize to tray after start-up (just like ScummVM does with windows 7 and thei have no solution yet to that)

post-5698-1290710471_thumb.jpg

Share this post


Link to post
Share on other sites
Bump?

 

do we got any solution everyone is satisfied with (well expet me lol) having troubles to get a grip of this thread (but that is my problem only) but stil...

 

Well, I've not been able to get C&C TFD to run. I've tried the options.ini fix and all of the compatibility fixes.

 

The game isn't hanging, though... it's not recognizing the DVD. It gets to the TFD start screen and when I select a game (say, Generals), the splash screen shows up and then it asks to insert the DVD. The DVD is in the computer and it's a paid-for copy. I've seen a couple others have this problem, but as yet have not heard of a fix.

 

I have a HP i7, with 8 GB ram and 1GB video card (ATI Radeon HD 5570) and am running Win 7 Home Premium (64bit).

 

Thanks for any help.

 

Dean

Share this post


Link to post
Share on other sites
Well, I've not been able to get C&C TFD to run. I've tried the options.ini fix and all of the compatibility fixes.

 

The game isn't hanging, though... it's not recognizing the DVD. It gets to the TFD start screen and when I select a game (say, Generals), the splash screen shows up and then it asks to insert the DVD. The DVD is in the computer and it's a paid-for copy. I've seen a couple others have this problem, but as yet have not heard of a fix.

 

I have a HP i7, with 8 GB ram and 1GB video card (ATI Radeon HD 5570) and am running Win 7 Home Premium (64bit).

 

Thanks for any help.

 

Dean

 

My brother had the same problem on his PC. As I have found so far, doing any of the fixes listed above will not work. In fact, you won't want to do them at all. Doing them will result in the faliure to read the disk. If you instead run it WITHOUT the compatibility options and DO NOT put the .ini file in the documents folder, it will run, but most of the Bink Video subsystem won't work for some reason. I'm trying to figure out why Bink Video won't function correctly, and when I get a solution, I'll post back. However, unless you're overly fond of the intro videos to the missions or the battle on the title screen, you won't really notice much of a difference.

Edited by rtsking117

Share this post


Link to post
Share on other sites
Bump?

 

do we got any solution everyone is satisfied with (well expet me lol) having troubles to get a grip of this thread (but that is my problem only) but stil...

 

Not yet. Technically there won't be a solution because the platform will continue to change.... but I think we're getting close to something reasonably permanent.

Share this post


Link to post
Share on other sites

just registered to add one thing i kept on missing.

 

when creating options.ini make sure file icon has a gear on it. I created txt file and renamed without thinking windows was hiding filextentions and my file was named options.ini.txt

i lost atleast an hour thanks to something that simple.

 

 

so if you are used to rightclick in a folder and pick new text file then rename it directly ur like me...

 

my advice is to all to uncheck "hide known filetype extentions" in your folder options. then this mistake never happens.

 

Share this post


Link to post
Share on other sites
Yey hidden extensions. Microsoft: keeping their customers dumb.

 

 

You can't blame them. Screwing around with the system isn't really a good thing. Especially since .ini files, when loaded correctly, are added to the registry.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×