Jump to content
Johnnyxp64

How To Play Generals / Zero Hour In Windows 7 X64

Recommended Posts

rtsking117    0
Oh please. C&C1 missions are .ini files.

 

 

Note: .ini files, WHEN LOADED CORRECTLY, are added to the registry.

 

anyone can use the extension .ini. however, when loaded the way it was DESIGNED (in Win16), Windows added the contents of the file to the registry.

Share this post


Link to post
Share on other sites
Nyerguds    73

no, only .reg files are added to the registry, and only when you actually tell it to do so. While there are some system-related ini files (unrelated to the registry though; just related to the OS' booting mechanisms), you generally don't find them anywhere in My Documents.

 

Pretty much ALL reasonably-sized DOS and Win95/98 era programs used ini files for their program configuration. It's not an operating system related thing, it's just a file format. And a very loosely defined one at that, too.

Share this post


Link to post
Share on other sites

I too was having difficulty setting up CNC Generals and Zero Hour. It took me several try's to figure it out. I see in previous posts a few different methods were used. My issue was my screen resolution. I copied the .ini file script and successfully saved the file as Options.ini and left the resolution in the script as 1024x768. I did not set anything as to run as Administrator or to run in compatibility mode. The main issue I had was my new laptop resolution is set to 1600x900, CNC Generals and Zero Hour only work on 1024x768. Once I changed my desktop resolution on the initial startup of the games using the ini file in both data folders the game launched. after running both games for the first time I was able to change my desktop resolution back to 1600x900. CNC automatically adjusted the resolution after that. Below is the script. Just copy and paste it into note pad and save it. Select all files for file format and type options.ini for the file name. Then copy and paste the file into the Generals and Zero Hour data folder located in the Documents folder formerly My Documents.

 

 

AntiAliasing = 2

BuildingOcclusion = yes

CampaignDifficulty = 0

DynamicLOD = no

ExtraAnimations = yes

GameSpyIPAddress = 0.0.0.0

Gamma = 50

IPAddress = 0.0.0.0

IdealStaticGameLOD = High

LanguageFilter = true

MaxParticleCount = 5000

MusicVolume = 33

Resolution = 1024 768

Retaliation = yes

SFX3DVolume = 79

SFXVolume = 71

ScrollFactor = 65

SendDelay = no

ShowSof****erEdge = yes

ShowTrees = yes

StaticGameLOD = High

TextureReduction = 0

UseAlternateMouse = no

UseCloudMap = yes

UseDoubleClickAttackMove = no

UseLightMap = yes

UseShadowDecals = yes

UseShadowVolumes = yes

VoiceVolume = 47

 

Share this post


Link to post
Share on other sites

Hi!

I tried to run Generals(Zero hour) and i followed the instructions but it gives me a message that i need directX8.1 or above or that maybe my VGA is old however,i have directX11 and NVIDIA GT220 and i installed DirectX 9.0c full package and still no good,it's giving me the same message.I want to mention that my PC is Win7 32bit and not 64.

post-7704-1296567530_thumb.jpg

post-7704-1296567588_thumb.jpg

Share this post


Link to post
Share on other sites
Nyerguds    73

The message says something else too... might be worth looking into which cards are supported by Generals.

Share this post


Link to post
Share on other sites
Tore    26

Make sure that you are running the game at a resolution your monitor supports. Else the game will moan about DirectX versions for some strange reason.

Share this post


Link to post
Share on other sites
Whisk33    0
Hi!

I tried to run Generals(Zero hour) and i followed the instructions but it gives me a message that i need directX8.1 or above or that maybe my VGA is old however,i have directX11 and NVIDIA GT220 and i installed DirectX 9.0c full package and still no good,it's giving me the same message.I want to mention that my PC is Win7 32bit and not 64.

 

I had this problem once and EA told me to delete the Game.dat file. Try that. (Just move it to a different location i.e. the recycle bin temporaily.)

Share this post


Link to post
Share on other sites
din_dinez    0
umm... isn't game.dat the game executable? I can't imagine how deleting that could solve anything.

 

 

 

i have a problem....can some one help me....i try to run c&c zero hour...

 

 

you have encountered a serious error. serious errors can be caused bye many things including viruses, overheated hardware and hardware that does not meet the minimum specifications for the games.

 

help me plzzzzz :(

Share this post


Link to post
Share on other sites
Plokite_Wolf    144

If you have Windows Vista/7, refer to the first post of this thread.

If you have Windows XP, see if you have the game properly installed and patched, if you have files leftover from a mod, and if your game has a sloppily cracked exe.

Share this post


Link to post
Share on other sites
din_dinez    0
If you have Windows Vista/7, refer to the first post of this thread.

If you have Windows XP, see if you have the game properly installed and patched, if you have files leftover from a mod, and if your game has a sloppily cracked exe.

 

 

i try it already.....but the result still the same......

i use windows7....(window NT)

Share this post


Link to post
Share on other sites
gaircity    0
Recently i installed from TFD, Generals Zero hour for some old good fights after i saw in you tube the Generals Trailer 1 at E3 that made me wanna revisit that game.

 

Now i am running Windows 7 x64 and after installation the program didnt run.

 

so here is what you should do to make it run

  • Make sure you have the latest DirectX 9.0c installed, you can Google it or get it from Microsoft
  • into your "user" directory (named with your user account yeah you know there where you see the folder my pictures, my music etc)
  • in there go to "My Documents"
  • well there after trying to run the game you would see a Command and Conquer Generals Zero Hour Data folder.
  • open it.
  • right click and creat new empty .TXT file and rename it options.ini
  • copy those lines inside and Save it!
**warning in the resolution section put your resolution*********

 

AntiAliasing = 2
BuildingOcclusion = yes
CampaignDifficulty = 0
DrawScrollAnchor = yes
DynamicLOD = no
ExtraAnimations = yes
GameSpyIPAddress = 0.0.0.0
Gamma = 50
HeatEffects = yes
IPAddress = 0.0.0.0
IdealStaticGameLOD = Low
LanguageFilter = false
MaxParticleCount = 5000
MoveScrollAnchor = 
MusicVolume = 50
Resolution = 1440 900
Retaliation = yes
SFX3DVolume = 72
SFXVolume = 64
ScrollFactor = 145
SendDelay = no
ShowSof****erEdge = yes
ShowTrees = yes
StaticGameLOD = Custom
TextureReduction = 0
UseAlternateMouse = yes
UseCloudMap = yes
UseDoubleClickAttackMove = no
UseLightMap = yes
UseShadowDecals = yes
UseShadowVolumes = yes
VoiceVolume = 78

 

  • then Right Click on your Generals / Zero hour Sortcut (if you dont have make one), in widows 7 most games make there sortcuts into the "GAMES" menu in Start Menu :huh:
  • and in the Compatibility Tab just select Windows XP sp3 and click "Run as administrator" option too (if you are not an admin)
  • thats it go inside change your settings and restart the game.

have fun thats an order! :lol:

 

<object width="635" height="385"><param name="movie" value="

name="wmode" value="transparent"></param><param name="allowFullScreen" value="true"></param><embed src="
type="application/x-shockwave-flash" allowfullscreen="true" width="635" height="385"></embed></object>

 

SO...I did exactly this, and it made the game (Zero Hour) open and run normally, right up to the point when I actually get past the menu and start playing. After I build just a few dozers and one building everything get blown to bits and I am told that I have been defeated. From what I understand this is a form of copyright protection for the game; if any files get modified the auto-defeat option turns on. If I remove the options.ini file from the data folder then the game glitches on the splash screen and we are back to square one. Any ideas? Win7 64 Ultimate, lots of power, legit game and legit game key. The same problem happened with Generals, but the options.ini file worked beautifully and I can play it no problem. I have reinstalled multiple times, manually deleting leftovers from the install each time, no effect.

Anyone that can solve my problem has beer and a bed next time they are in Alberta!

Share this post


Link to post
Share on other sites
Plokite_Wolf    144
SO...I did exactly this, and it made the game (Zero Hour) open and run normally, right up to the point when I actually get past the menu and start playing. After I build just a few dozers and one building everything get blown to bits and I am told that I have been defeated. From what I understand this is a form of copyright protection for the game; if any files get modified the auto-defeat option turns on. If I remove the options.ini file from the data folder then the game glitches on the splash screen and we are back to square one. Any ideas? Win7 64 Ultimate, lots of power, legit game and legit game key. The same problem happened with Generals, but the options.ini file worked beautifully and I can play it no problem. I have reinstalled multiple times, manually deleting leftovers from the install each time, no effect.

Anyone that can solve my problem has beer and a bed next time they are in Alberta!

This glitch is common in RA2 too. Have you tried installing the game in a directory different than Program Files (I hear that it's quite a pest in Win7)? :huh:

Share this post


Link to post
Share on other sites
Sundisco    0

Hai all!

 

i have a problem....can some one help me....i try to run c&c zero hour...

 

 

you have encountered a serious error. serious errors can be caused bye many things including viruses, overheated hardware and hardware that does not meet the minimum specifications for the games.

 

help me plzzzzz :(

 

I have the same problem.. even tho i know my system requirments should be far beyond enough..

Im running Win 7 64bit.. and i did make the ini file and the maps folder, i tried to use these resolutions in the ini file, 800 600, 1280 1024, 1024 768. non of these seem to work.. or there must be another error or something..

I also allowed all the rights u could get in the security tab of the CNCGZH shortcut, and i put WinXpSp3 as compatibilitymodus, and im Running the porgram as administrator.

 

so whenever i try to startup the game u see the beginscreen.. then when it goes away i get the error msg "you have encountered a serious error. serious errors can be caused bye many things including viruses, overheated hardware and hardware that does not meet the minimum specifications for the games. contact ea blablabla"

 

I hope u guys know an answer for me im dying to play this game

 

Thanks! Sundisco.

Share this post


Link to post
Share on other sites
Plokite_Wolf    144

Alright, lads. First tell us if you tried anything from the first page of this thread, don't just spam new posts.

Try this:

 

Way to make this thing work on an operating system that tries (unfortunately, cause i kinda like win7) to fight you the whole way:

 

1. Add a Maps folder and the Options.ini file to ...\My Documents\Command & Conquer Generals (Zero Hour) Data\

2. Install DirectX 9.0c from Microsoft.com

3. Disable UAC (User Account Control - Generals/Zero Hour are most likely not compatible with UAC)

4. Right click on generals.exe (this works on both) and click the compatibility tab

5. Check all of the following:

-1. Run in compatibility mode (i ran it in WinXP w/SP3)

-2. Run as Administrator

-3. Disable Visual Styles (this disables the aero style of the Vista virus and win7).

-6. Save the changes and attempt to run the .exe

Share this post


Link to post
Share on other sites
Sundisco    0
Alright, lads. First tell us if you tried anything from the first page of this thread, don't just spam new posts.

Try this:

 

doesnt make sence.. u cannot install directX9c over direct x11 :S.. i did all the steps and still it aint working :(

 

This txt file appeared in my C:\Users\......\Documents\Command and Conquer Generals Zero Hour Data

 

Release Crash at Thu Mar 10 13:53:27 2011

; Reason Error parsing INI file 'Data\INI\Object\mines.ini' (Line: 'Object EMPMineEffectSpheroid ')

 

 

Last error:

 

 

Current stack:

 

 

Share this post


Link to post
Share on other sites
Plokite_Wolf    144
doesnt make sence.. u cannot install directX9c over direct x11 :S.. i did all the steps and still it aint working :(

 

This txt file appeared in my C:\Users\......\Documents\Command and Conquer Generals Zero Hour Data

 

Release Crash at Thu Mar 10 13:53:27 2011

; Reason Error parsing INI file 'Data\INI\Object\mines.ini' (Line: 'Object EMPMineEffectSpheroid ')

 

 

Last error:

 

 

Current stack:

Seems you have a mod with a bug (mines.ini is not a regular Zero Hour file) :huh: Delete all mods, patch the game to 1.04, don't use sloppy No-CD cracks.

You CAN downgrade DX. It's a must when playing older games (for instance, that is the only way you can play Star Trek Armada II on Vista/7).

Edited by Plokite_Wolf

Share this post


Link to post
Share on other sites
Sundisco    0

yes thats correct i had the error from the beginnin then i tried contra7 and the same error stayed...ok thanks ill try everything agian delete all files and reinstall all the files.., and also the dx9c.. ull hear again if it doesnt work.. cuz i wont stop msging untill this game works on my pc! :)

 

Thanks again :)

Share this post


Link to post
Share on other sites
valkyrie    0

Hi,

I've tried many Options.ini, i have problem with DirectX8.1 despite I installed the lastest version.

I changed the resolution: nothing.

I've started with "run as an administrator": nothing.

I have the blue windows "command & conquer", the screen change resolution, and then back to windows.

 

I passed 2 hours, and it's not working.

Someone can help me?

I really need it, we want absolutely do a LAN.

 

Thank you.

 

(sorry for my english i'm french)

Edited by valkyrie

Share this post


Link to post
Share on other sites
Plokite_Wolf    144

Have you tried:

- compatibility modes

- running as Administrator

- reinstalling

- installing in a folder other than Program Files

- downgrading your DirectX to 9.0c (ignore DX10/11, they don't seem to run Generals)

- checking if Options.ini has a notepad and gear in the icon (if not, that would mean that the file is called Options.ini.txt)

- patching the game to 1.04 (Zero Hour) and 1.08 (normal Generals)

- deleting sloppy No-CD cracks

Edited by Plokite_Wolf

Share this post


Link to post
Share on other sites
valkyrie    0

I reinstalled

I have the gear on Options.ini

I'll try to patch the game...

But i really think it's a problem of Options.ini code due to the resolution. But i've tried all codes on the net, and it doesn't work...

 

It's seven 64bit, my card is a ATI HD 5470

Share this post


Link to post
Share on other sites
Plokite_Wolf    144
i have problem with DirectX8.1 despite I installed the lastest version.

Find DirectX 9.0c somewhere. It might work after that. DX 10 or 11 don't seem to run Generals.

Also, try to run the game in compatibility for WinXP SP3

Share this post


Link to post
Share on other sites
DIMITRIUS    0
Find DirectX 9.0c somewhere. It might work after that. DX 10 or 11 don't seem to run Generals.

Also, try to run the game in compatibility for WinXP SP3

 

 

PLZ help how can i downgrade DX???? i have win7 and dx11 and it has got error all the time!!!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×