Jump to content
Johnnyxp64

How To Play Generals / Zero Hour In Windows 7 X64

Recommended Posts

I tried clean install of G:ZH on clean Win7. Without and with patches. Without and with directx_Jun2010_redist. All the same... Game starts and runs fine, except corrupted textures. And again, if I reboot and switch to WinXP, goto installation folder and start generals.exe, game running with no texture problems.

Share this post


Link to post
directx_Jun2010_redist.

Why that specific redist? Try with this. This should repair your DX9, and it allegedly works in Win7 too.

Share this post


Link to post

If you're running Windows 7, you shouldn't even need to install any versions of DirectX. The video device itself might be the issue since it's incapable of higher versions of DirectX, and Windows 7 doesn't need to have 9.0c installed since it runs by default.

 

Are your graphics drivers all the way up to date? Are you using the very latest drivers? nvidia released an update not that long ago. Install the 280.26 driver update and go from there.

 

What's your make and model of the video card? I know it's a geforce 6600, but who made it?

Share this post


Link to post

Finally I found an answer. Nvidia driver + my video card is the clue.

What I did:

I found and clean installed VISTA SP2. Tried Generals - and all OK!. Then I checked default Vista's video driver in device manager - it's ver.7.14.10.9687 dated 22.08.2006.

Then I installed current driver. It's ver.8.17.12.8026 dated 03.08.2011. Then ran Generals again - and here it is, white terrain!

Rolled back to default driver - all became normal.

So, I guess, I got to find some older driver version (older then default of Win7, something between 2006 and 2009), which would handle this video card right.

The vendor of the card is Inno3D.

Thank U all for help! Maybe U can tell me where can I find an archive with older Nvidia drivers for Vista/7? Because official site's archive is only from now till 2010.

Share this post


Link to post

It's not advised to use old drivers. There's a reason new drivers exist and they tend to fix issues that old drivers have. It's the age of your card, not necessarily the operating system or driver. Continuing to use an aging piece of hardware will invariably lead to issues exactly like this.

 

As a point of interest, your video card is not on the Windows Vista or Windows 7 hardware compatibility list. Take that as you will, but it's an indicator.

Share this post


Link to post

Well, I know it's old, but Vista and 7 both have default WDDM drivers that recognize it, and, official Nvidia drivers are claimed to support it, so, it is partial incompatibility. Generals is one and only game caused an issue among all the games and apps I ever used on this PC. I'll just make partition backup and give older driver a try. If anything goes wrong, i'll restore and try something else...

Share this post


Link to post

If it works on XP, and it sounds like the same computer, so if you want to play ZH, do so on XP. I would say the age of the card is why W7 is struggling with it.

Share this post


Link to post

After some research I found out that driver 178.24 whql is the latest compatible with Generals on GeForce 6600 on Win7. Although it's Vista driver, it installs on Win7 with no problems. And it gave me quite good game performance. Aero works, overcloking (tried Nvidia Inspector) works, temperature monitoring works. So, I think, problem solved, maybe it'll be useful for someone. Thank U all for help!

Share this post


Link to post
Recently i installed from TFD, Generals Zero hour for some old good fights after i saw in you tube the Generals Trailer 1 at E3 that made me wanna revisit that game.

 

Now i am running Windows 7 x64 and after installation the program didnt run.

 

so here is what you should do to make it run

  • Make sure you have the latest DirectX 9.0c installed, you can Google it or get it from Microsoft
  • into your "user" directory (named with your user account yeah you know there where you see the folder my pictures, my music etc)
  • in there go to "My Documents"
  • well there after trying to run the game you would see a Command and Conquer Generals Zero Hour Data folder.
  • open it.
  • right click and creat new empty .TXT file and rename it options.ini
  • copy those lines inside and Save it!
**warning in the resolution section put your resolution*********

 

AntiAliasing = 2
BuildingOcclusion = yes
CampaignDifficulty = 0
DrawScrollAnchor = yes
DynamicLOD = no
ExtraAnimations = yes
GameSpyIPAddress = 0.0.0.0
Gamma = 50
HeatEffects = yes
IPAddress = 0.0.0.0
IdealStaticGameLOD = Low
LanguageFilter = false
MaxParticleCount = 5000
MoveScrollAnchor = 
MusicVolume = 50
Resolution = 1440 900
Retaliation = yes
SFX3DVolume = 72
SFXVolume = 64
ScrollFactor = 145
SendDelay = no
ShowSoftWaterEdge = yes
ShowTrees = yes
StaticGameLOD = Custom
TextureReduction = 0
UseAlternateMouse = yes
UseCloudMap = yes
UseDoubleClickAttackMove = no
UseLightMap = yes
UseShadowDecals = yes
UseShadowVolumes = yes
VoiceVolume = 78

 

  • then Right Click on your Generals / Zero hour Sortcut (if you dont have make one), in widows 7 most games make there sortcuts into the "GAMES" menu in Start Menu :huh:
  • and in the Compatibility Tab just select Windows XP sp3 and click "Run as administrator" option too (if you are not an admin)
  • thats it go inside change your settings and restart the game.

have fun thats an order! :lol:

 

 

Thank you so much, just made a acc to say thx.

Btw love this side by now

 

 

Share this post


Link to post

Someone please tell me where can i download an official version online. I want to play it on a net book but there is no disk slot for it. I have the disk and the code ready to put in, but the websites i have gone to don't give me official versions.

Share this post


Link to post

Greetings

 

The problem which I'm facing with ZH on Win 7 is a bit different in nature which no one else has so far posted about, but resulting in the same serious error whose crash log says: "The thread tried to read from or write to a virtual address for which it does not have the appropriate access"

 

I've got the Generals AND The ZH cracked versions (along with the 1.08 and 1.04 patches respectively) from "TheXsision" torrent.

 

I finished the Generals without any problems. And then installed ZH 1.04 in a folder separate than the first Generals... and not in the Program Files.

 

I didn't face ANY problems in running this game on Win 7... It starts and run perfectly and for that I didn't have to modify anything in options.ini or set the game properties to "run as admin" (I log into the computer as admin)

 

Then...

 

Finished the USA Campaign (on Medium) all perfect.

 

Problem started with GLA's 2nd mission. And the problem is... that when I save while playing... and then try to load the saved game... then only sometimes it loads but mostly it crashes back to windows shortly after showing the loading progress bar!!!

I deleted the corrupted save and tried saving again while playing but again the same... sometimes it loads but mostly it gives the same annoying message.

 

 

I've gone through the whole thread and so far nothing has worked for me. I've even tried re-installing/re-patching he game... but no success. Also tried patch 1.06 from http://www.gamereplays.org/community/index...howtopic=380765

but same results.

 

Kindly help

Share this post


Link to post
I've got the Generals AND The ZH cracked versions (along with the 1.08 and 1.04 patches respectively) from "TheXsision" torrent.

Might be that TheXsision can't make the cracks right. We don't actually give support to pirated versions, according to the forum's rule #13, found in the Rules & Guidelines section.

 

13. Don't post or discuss anything related to copied/ripped/downloaded versions of any games (C&C or otherwise) or other software applications. Under no circumstances should you post questions or replies offering methods to circumvent copy protection schemes. This includes asking for or offering links to "NoCD" patches for any games (C&C or otherwise) or other software applications. The only exception to this rule is for the free versions of Command & Conquer, Red alert and Tiberian Sun made available by Electronic Arts.

Share this post


Link to post

Thank you for your instant reply.

 

I understand and respect the policy.

 

And this was my first thought too that may be the crack has something wrong with it... but then I read this forum and to my surprise so many people are having problems with legit versions.

 

If you kindly allow me to ask... have you encountered/heard of such a problem... that starting ZH in Win 7 is no issue at all... but in a particular regular mission (GLA 2nd in my case)... loading the saved file is causing this "serious error"

????

 

If you can suggest any solution, I'll be very grateful.

Share this post


Link to post
Guest Rabbit

Sorry, but to put it simply, we're not going to discuss this issue with you on the pure basis of the way you got your copy of the game.

 

In the old days, you'd find yourself banned, but I'm more inclined to simply encouraged you to purchase a legal copy of the game, as you'll likely find all of your problems fixed by simply doing that. Better yet, buy "The First Decade," and you'll have all the C&C games before C&C 3, and I'm sure your problems will be solved. ;)

Share this post


Link to post

Here is what you should check that you have done, if you are STILL looking for a fix :P

 

Create a new notepad document, put the config stuff in there (I only used the two lines below and it worked for me, then generated the rest).

 

Put these two lines in there;

 

IdealStaticGameLOD = Low

 

StaticGameLOD = Custom

 

NOW, here's the important part that I think others of you have missed.

 

Go to file: Save as.

 

In the bottom of the save window, in the dropdown list entitled "Save as type", change it from "text documents" to "All Files"

 

That way, it saves it as a proper .ini config file instead of a text file. You would have been getting "options.ini.txt" instead of the correct "options.ini"

 

Apply those compatibility settings (XPSP3 or XPSP2, disable visual themes, disable desktop composition).

 

I was getting the same problems as you were, then clicked to that fact and performed the steps above. It then worked perfectly.

 

Hope this helps you guys! :gen:

Share this post


Link to post

i own a Macbook pro 4gb i7, i installed VMWARE FUSION 4 so i can run a window on the computer, at first i installed the win7 ultimate 32bit and the game worked nicely but at times it would get really slow so i decided to give it a try on 64bit. i heard people got it working but i cant figure it how, did all of the above, .txt file .ini, everything and still get the same error which is: Please make sure u got directx 8.1 or a higher version installed. Also check if your video card makes the requirements. ( i doubt is the video because i got it working before on this computer with the 32bit. PLEASE SOMEONE HELP i dont want to get back to the 32bit, its slow... but if thats my last choice i will, i freaking love this game! hope someone has a solution.

Share this post


Link to post

If you have a Mac your probably better off purchasing a copy of Generals/Zero Hour for that OS.

Share this post


Link to post

wow I haven't read this thread for months! and now i see 100+ posts?!!!

anyway just to comment on the above that DD said.

 

i am sorry but that's not true! you see even thought the Direct X 11.1 for example are higher in number than 9.0c, there are directx 9.0c libraries that are not included in the latest dx version not even 11.x and the game was coed to use those specific version back then!

 

so by simple reinstalling directx9c libraries you simple "fill up the gaps" and missing files.

 

like the Media player classic, for example, for some DX filter it need dx9!

 

also 11.1 that is installed in a windows 7 system its NOT the same like 11.1. SDK libraries for example! its just the runtime libraries!

 

there are different versions for different reasons, and installing dx9c in a w7 its doing no harm at all! on the contrary! :thumbsup:><

 

anyway that's all.

 

BTW i have updated post 1 with more clarifications!

Share this post


Link to post

I'm pretty sure I didn't install anything DX9 related and everything I have runs like a champion.

Share this post


Link to post

HI

Whay C&C generals run perfect in my windows7 ,but C&C ZH didn't run and show me this message

 

Technical Difficulties

 

You have encountered a serious error. Serious errors can be caused by many things including visurses, overheated hardware and hardware that does not meet the minimum specifications for the game. Please visit the forums at www.generals.ea.com for suggested courses of action or consult your manual for technical support contact information.

 

Can anybody help me to run ZH pleaseee

Share this post


Link to post

This is the most common and general screen . It gives no info whatsoever. Try everything from this thread.

Share this post


Link to post

hi

i tried everything and still i have problem with that message , in my dokuments i found this report

 

Release Crash at Sat Jan 21 16:58:40 2012

; Reason Uncaught Exception in GameEngine::update

 

Last error:

Exception is access violation

WinMain at 401700

Error code: EXCEPTION_ACCESS_VIOLATION

Description: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.

Access address:00000003 was read from.

 

Stack Dump:

<Unknown>(-1) : <Unknown> 0x0080328A

<Unknown>(-1) : <Unknown> 0x3F800000

 

Details:

Register dump...

Eip:0080328A Esp:0012F448 Ebp:00A47530

Eax:04B77C70 Ebx:09CA1ACC Ecx:00000003

Edx:00000001 Esi:00000008 Edi:00004000

EFlags:00210206

CS:001b SS:0023 DS:0023 ES:0023 FS:003b GS:0000

EIP bytes dump...

 

Bytes at CS:EIP (0080328A) : 8B 11 56 FF 52 18 EB 09 56 E8 F8 75 01 00 83 C4 04 A1 30 7F A4 00 8B 88 24 01 00 00 46 83 C5 04

 

 

Current stack:

Share this post


Link to post

@dd i am sure some dx9c files were installed from other game setups without even noticing it, its a common task of the game setups. :)

 

anyway @kotlla

it seems you havent upgraded your game..

 

just delete everything, unisntall the game

delete all your folders or move them to an other location for backup like a USB stick

 

also give us more details on what are you trying to install? Generals? zero hour? from which version? the First Decade? do you have it original or a crappy cracked version?

you dont give any details and dont expect us to give you any "harry potter" solution ;-)

 

generally speaking a good installation even if you crack the game with a no cdcrack (even though i do not recommend pirecy)

you should be able to play! the game works just fine! maybe your system has other issues like old drivers, a virus infaction.... bad cracked copy of the game..etc...

 

give us specific details to give you more specific solutions otherwise we are both wasting our time :rolleyes:

Edited by Johnnyxp64

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×