Jump to content

Recommended Posts

How can I add new countries to Red Alert 2? :ra2: Please don't just tell me to download NPatch. I already did, but it confused me. Please try to make it easier to understand. Or, I'm much better at learning when I see how someone else does it, so could someone upload a youtube video of how and post a link to it on here for me? If this helps at all, the country I'm trying to add is the Philippines.

Share this post


Link to post

Use the NPatch and follow the MDK. It tells you exactly how to add a new country. I realize the English VK used is kinda.. well... bad, but it's not hard to follow.

Share this post


Link to post

Maybe it's not hard for you. You know how. I'm still learning. I've tried at least 10 times and failed every time. I know one thing we could do. Can you make it for me and Email it to [email protected]? If so, then from now on, I can use this one as an example.

Share this post


Link to post

I'm confused at the tables. Here are some things I don't understand.

 

1. After I get all the files for flags and loadscreen, do I have to put filenames in rules.ini or art.ini?

2. Where do I type stringable entries, rules.ini or ra2.csf?

3. What do load brief and status bar text mean?

Share this post


Link to post

1) You don't reference them anywhere. The EXE does it all automatically if you name them right.

2) ra2md.csf. The RockPatch/NPatch do not affect Red Alert 2. Period.

3) Load brief is what you see on a multiplayer loading screen and status bar text rolls on the bottom when selecting a country from the drop down.

Share this post


Link to post

So, are you saying that it can't be done for RA2, only YR? If so, then I have another question. I wanted it for RA2 for multiplayer because I have two CDs, but for YR, I only have one. Is there any way to play YR without the CD?

Edited by CommanderGerman

Share this post


Link to post

There is but if you intend to LAN it, you need CD keys for everyone playing. You can't run it off the same one.

Share this post


Link to post

Well, I tried for YR and it is working, but with a few problems.

 

1. It still says Missing Name:Country10 even though I did add the string.

2. There's a big black place where it should show the flag.

3. The loadscreen is the wrong color. Which pallette should I use?

4. Right when the game loads, it says "You are victorious". I don't even get to play.

Share this post


Link to post

1) Did you use NAME:Country10 in the rules or Name:Country10? Case is important.

2) Do you have a flag?

3) ls10_pal.pal is what you need. You'll need to create a new one.

4) That's more than likely the anti-piracy measure taking effect. You'll need to reinstall the game to fix that.

Share this post


Link to post

For questions 1 and 2, I figured out the answers myself.

3. Yes, I do have a flag.

4. It's even worse now. Now, my country isn't even showing up.

Share this post


Link to post

Sorry to drop in, but can you add an country by using TibEd...

Share this post


Link to post
For questions 1 and 2, I figured out the answers myself.

3. Yes, I do have a flag.

4. It's even worse now. Now, my country isn't even showing up.

3) You have the small flag PCX file? Keep in mind the little country flags must be in PCX format.

4) Did you add your country to [Countries] and [sides]? And did you make sure to move Civilian, Special, GDI and Nod to the end of the countries list? And did you add NewPlayableCountries=1 to [General]? It takes quite a bit with NPatch to add a new country.

 

Sorry to drop in, but can you add an country by using TibEd...

No you cannot.

Share this post


Link to post

3. It is a pcx file, but it's really big. That's probably the problem.

4. After reinstalling the game, all I diid was put all the files back in the RA2 folder that I already had: c10_flag.pcx, c10_ls.shp, c10_ls.pal, ra2md.csf, rulesmd.ini, and artmd.ini.

 

After I reinstalled, none of my mods are working. I have already updated to Version 1.001 which was the version I had originally. What's the problem?

Share this post


Link to post

Ok, mods are working again. :) The bad thing is that it still says You are victorious right after the game loads.

Share this post


Link to post

Then you need to uninstall and reinstall entirely. But before you do that, does it happen with every country or your new one?

Share this post


Link to post

I'll gather it's not a new faction. Did you add your new country to all of the appropriate Owner lists? Especially on the MCV.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×