Jump to content
Sign in to follow this  
Skorzeny8814

How to edit textures of the game?

Recommended Posts

I've downloaded TIbEd Professional for Red alert 2 Yuri's revenge because I thought I could edit the ingame textures with it. Now I think I can't :( I've read the turials and google it, but nothing. I don't understand why I can't find anything about it, I saw mods with modified textures. How do I edit them?

Share this post


Link to post

You'll need the XCC Mixer (part of XCC Utilities) to extract shp files. Download links are provided in the pinned "RA2/YR Modding tools" topic within this forum.

Share this post


Link to post

You'll need the XCC Mixer (part of XCC Utilities) to extract shp files. Download links are provided in the pinned "RA2/YR Modding tools" topic within this forum.

Thanks! That's one more step forward :) But I have another problem here. I open the .mix files, but the utility shows me the pictures (on the right side of the window) of just a few of them (for example the in-game menu parts). Most of them is shown as a black square. Am I doing something wrong?

Share this post


Link to post

Hmm... I'm not sure I understand what you mean, could you take a screenshot so I can see specifically what you are talking about?

Share this post


Link to post

Hmm... I'm not sure I understand what you mean, could you take a screenshot so I can see specifically what you are talking about?

Here it is:

screen.gif

Edited by Nmenth
fixed image

Share this post


Link to post

The urls are used in this way:

 

[img=http://www.example.com/image.png]

 

You can upload images, but you need to do so in the full editor (click on the More Reply Options button). Then, you'll see an attachment area below the text window which allows you to upload attachments (regular users have a very low upload limit, so compress it to JPEG or PNG). Then attach the selected file to the message and post it.

Share this post


Link to post

The urls are used in this way:

 


[img=http://www.example.com/image.png]

 

You can upload images, but you need to do so in the full editor (click on the More Reply Options button). Then, you'll see an attachment area below the text window which allows you to upload attachments (regular users have a very low upload limit, so compress it to JPEG or PNG). Then attach the selected file to the message and post it.

I've edited the post, now you can see the picture URL. I couldn't use my picture's URL as it was in your example because it said I can't use this type of image on the site.

Edited by Skorzeny8814

Share this post


Link to post

That's because you were using the address to the site where the image was located rather than to the image itself. I edited your post to show the image correctly.

 

That aside, I've never seen the frames appear as those solid black boxes before, they show up like that for every file you select? Did you select a palette from the View menu? That shp should be viewed with the RA2 anim.pal palette.

Share this post


Link to post

That's because you were using the address to the site where the image was located rather than to the image itself. I edited your post to show the image correctly.

 

That aside, I've never seen the frames appear as those solid black boxes before, they show up like that for every file you select? Did you select a palette from the View menu? That shp should be viewed with the RA2 anim.pal palette.

That was the problem! I've changed the palette to RA2 anim and now I see the textures. Thank you!

 

edit: But the images look very crap, not like in the game.

 

screen.gif

 

edit: Sorry, shp editor can see them correctly.

 

Thank you for helping me.

Edited by Sonic

Share this post


Link to post

But the images look very crap, not like in the game.

You have to have the right palette selected, animations use the RA2 anim.pal, units and buildings use the RA2 unittem.pal, if you don't know what palette to use, just use ctrl+] to go through them until you can find one that works.

Sorry, I still don't understand, what did I wrong, with the picture URL. I pasted the URL of the picture itself, not just the sites

You have to right click the image to acquire the image's address which in the case of above is http://s14.postimg.org/ky4zajxo1/screen.gif whereas the page which the picture is on is the http://postimg.org/image/z4kq5s8j1/ you are trying to use. If the address isn't ending with an image file name, it can't be posted (.gif in this case).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×