Jump to content
Sign in to follow this  

Zero Hour (Serious Error)

Recommended Posts

Good to see everyone's still here! Anyways, to the problem...


Zero Hour has been giving me an error, same goes w/ Generals, it loads the large screen (with the Unofficial Patch) and then it hangs there, with about a minute passing, the error shows up. I am unable to get into the game, just the loading screen BEFORE the game.


I have looked around and did everything that there was, from using Windows XP SP3 compatibility to putting in the options.ini in the My Documents ZH folder. I've also done the same with the TFD Launcher and ran it as an admin, still no progress. All the other games, YR, Red Alert 2, Tiberian Dawn and RA1 (all though they get really weird colors so I do the 'open screen resolution before TFD' trick) work with out a problem.


Yes, the game's legitimate, no cracks or anything of a sort. Please help. :/

Share this post

Link to post

Run the game itself as administrator.


Install DirectX 9.0c - https://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=35



A complete reinstall can also fix the issue if nothing else can (and by that, I mean that you should remove all remaining files after uninstalling)

I apologize for not adding in this: I have ran the game as an administrator, which is one of the first troubleshooting things I do whenever it acts like this, I also saw that I needed DirectX 9 and installed it. No progress was made, still the same thing. I also did a clean reinstall, removing all the folders and installing the new ones.


For some reason, the DirectX installer tells me I have a newer equivalent, which I don't remember installing.

Share this post

Link to post

Fixed it!


I redid the step on doing the options.ini step and I set the "Save as type: All Files", so now I tried to open ZH again and it successfully launched to the menu, found all my graphics settings set up all the way up, no texture problems, shellmap moving as expected!


I may have mis-read the step posted awhile ago...well, either way, that's how I fixed it. Thank you, Plokite Wolf for your assistance, I appreciate it. :)

Share this post

Link to post

I'm using windows10 and am having the same problem as you did. except I don't know anything about the options.ini. help?


edit: okay, a youtube video showed me the options.ini thing and it works now. so happy

Edited by koonbeast

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.