Jump to content
Sign in to follow this  

First post here, need help getting a stupidly basic mod to work

Recommended Posts

I was directed here by someone on Reddit so I'll copy and paste, and include some stuff I forgot to mention.

So here's the deal, I'm trying to create a mod that will bypass the error stopping me from pitting two AI's against each other. I just want to watch two Brutals fight to the death, even if it means altering a a memory address in Cheat Engine. I know that on the Skirmish screen, you can select the enemy AI to be in the slots instead of you, but there's no way to close your slot - like I'm sure you could do in other games in the series, so it doesn't let you continue.

But I download the SDK and I saw an option in SkirmishAIData.ini called MakeAllSkirmishSidesAIControlled. But I can't for the life of me get a modified INI file working in the actual mod. According to this page, you have to first make a blank mod, build it using BuildMod.bat, make another folder inside your data folder called "INI", place the modified file in there and rebuild, but that just crashes my game on start-up. It complains about a file with "mod.manifest" in the title. In my attempted mod I just stripped away everything but "MakeAllSkirmishSidesAIControlled = No" and changed the No to Yes.

When I tried actually compiling the mod in BuildMod, it gave me a parsing error that it couldn't process INI files, which according to my Google-Fu, means that it was expecting to parse an XML document and received an INI file instead. Fine, that means I typed mod.xml correctly. But I can't find a single example of any mod using an INI file, and the Internet is pretty bare on solid tutorials that involve INI - most of it is changing unit stats or adding new units.

This is the specific error. It only happens when I open the mod from the mod menu in the launcher. I don't even know what data folder it's referring to, I don't even remember making a mod.manifest file because the few tutorials I did read never mentioned it.

(Upon initially writing this, I realised that the referred file was located in \Command & Conquer 3 Tiberium Wars\Mods\PlayAsAIMod\playasaimod\data, but Sample Mod doesn't even have a data folder in it. Am I being a very silly billy by putting a data folder here?)

Is it also a bit too late to suggest that the sample mod doesn't even work? It has 'Sample' all over the main menu screen, sure, but there aren't any new AI personalities or new units like the documentation said. Not sure if that's intentional.

This is all over the place, I do apologise, I've edited this many times. This is all the jargon given by the compiler, unlikely to contain anything useful and it's a pain in the ass to read, sorry.

Thanks in advance if anyone can help me with this issue, and I hope everyone's enjoying the new year.

Edit: I realised I had two nested folders with the same name, so I basically just took data and shaders one step higher so it's next to the .big and .skuldef files. Still giving me the same error though.

Edited by Bunny_Wabbit

Share this post

Link to post

haven't read most of your post tbh, but I've checked your compiler log and it's basically I all needed.

The documentation stated you'd need to install antlr and mvp.xml

You can just download them from my onedrive: https://1drv.ms/f/s!AuGWwjATR_55vD4FnSIzoRQzRbt6 (you'll need the antlr.astframe.dll, antlr.runtime.dll, and Mvp.Xml.dll)


Though if you only want to change an ini files you actually don't need that stuff, just having the ini in the right folder would work. (You wouldn't even need to use the mod sdk for that)

Edited by Lauren

Share this post

Link to post

Thanks for the links Lauren, I put those three files you mentioned in \MOD SDK\Tools and rebuild the mod, but I'm still getting the same errors (crash on startup and in the Command Prompt). I can't tell any differences so I'll link to the latest compiled results which I'll link to below with screenshots of my file trees - maybe you can see a difference I couldn't. Here's an album of those screenshots I put together on Imgur -  https://imgur.com/a/cO3EU

Edit: The Sample MOD works like a charm though, thank you! Just out of interest though, what did you mean about the INI files. I read there's a BIG extractor that allowed you to extract and re-insert INI files into the core files, is that what you mean?

Edited by Bunny_Wabbit

Share this post

Link to post

Basically if you want to compile a ini file with your custom mod you need to place the ini file at the following location:


and not in your /documents/Tibwars/mods/ directory as your screenshot indicates.

But make sure you installed the sdk + patch1.09 etc correctly.

  • Upvote 1

Share this post

Link to post

You also do not need to include the ini file in your xml.

Share this post

Link to post

I'm getting the exact same errors even though I fixed this organising. I even tried compiling a simple mod that reduced the cost of Mammoth Tanks to 100 credits and the build time of a second, and even that didn't work, giving me the same mod manifest BS like shown in the album in my previous post. So I'm thinking there's something else wrong than my file tree. 

Guys what does your \MOD SDK\BuiltMods look like?

Edit: Hey I fixed my practice mod! I had to change "Reference" in my XML to "All". What's the difference between those two things? I can't see anything that talks about it in the documentation apart from showing the whole include tag for the Sample Mod.

The documentation tells me not to put the tools Lauren mentioned in MODSDK/tools/, rather just //MODSDK/, but I'm going to assume it'll just search the entire folder and its individual directories anyway. I recompiled my PlayAsAIMOD - the one with the modified INI - and it doesn't give me mod.manifest errors anymore but it doesn't actually change anything. I need to find another INI entry to test if it actually reads INI files in general for me, so I can determine whether it's just that specific feature that doesn't work.

Edit 2: Okay I'm talking out my ass, they do in the tools folder, BuildMod told me off.

Edited by Bunny_Wabbit

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.