Jump to content
Sign in to follow this  

Question about Tibed

Recommended Posts

Good Afternoon, I am a Newbie on making RA2 Mod. I've downloaded 1.6 from webside but I've got few questions.


First of all, I can;t download the file that Tibed requires to run from nither windows or your site. The bar just goes to end and then shows fails information on schedule.....is the file really important?


Secondly, I've upgraded the Game files by autoupgrade program, however I still can not save my editted units into game...or, the game just can not run my setting? I did nothing but cloned GI and M60E and incresed 20% more than their original dam and range.......I've set few new weapon and other new unit by clone and edit original data.....but whenever I load my saving file, datas goes mass.....weapon data becomes units or setted data cannot be found, and so on...-_-!


Finally, can any one tell me how to make new country(or displace any); how to open other MOD for using their new sign pic and setting(I thought you can by using Tibed, isn't it?).


One last thing, I've sent payment 9.99 Euro by Paypal, mail address is [email protected], if those question above are because of haven't registed, please mail me and tell me the code after you recived payment, OK? Thank you very much and I wish you all have another wonderful day!

Share this post

Link to post

When he checks up with the site, Koen will help you in every way that he can.


I'm not sure on the windows download about the shows failed information.


With your changes can/have your tried to run the game with the changes. The game should run as normal. If any changes become incomplete the game will just crash going to the desktop with the error at hand. Unless there's something else causing this, look over what you have changed.


You can replace a country for a new one. Though some modders have claimed they have added a new side. But I'm sure it has a lot of coding to go along with it.


As a side note. If your really serious about adding a lot of stuff to the game for your mod you will need to go beyond this program since it's mainly a unit editor. It's very good for new modders and a quick reference to some tools. I know by first hand somethings cannot be changed or added with Tibed. One other program used widely for modding is the XCC program.


Check out http://www.tibed.net/index.php?page=tibedfaq if any of these answer any modding questions you might have. If you want a quicker reply you could try to give a private message or E-mail to Koen.

Share this post

Link to post

Thank you sooo much, §tìngèr, but do you know when can I reacive my code? What's the different between an unlocked Tibed and a test one?


Well, like I said, my first problem is about download, but without it, the truly first question is my setting just goes mass, datas mixed whenever I loaded them, like unit has new thing called like "10-GuardRange","1000-70", "8-bombable" or others( and one called "British,France,American...", I think this should in Belond space), even weapon data in unit list, also units like Romanov and others cannot be seen, the program will jump to desktop whenever you are cleck on them for trying to look their data. Also, cloned units have mass on "Armor" board, some of them shows "none" or "yes" or "100" ......I really don;t understand.


I've tried once to run game with change, I made a random Skirmish game, there are only cloned unit which absolutly same as original ones( for example, I made a unit cloned from Seal, use Boris' voice and AKM and Seal's pic and modle, cost 2000,but in fact I only have 2 SEAL on buinding board). What's going on?

Share this post

Link to post

One last thing, I've seen some mods using new modle or RA1 units(like medic, flamethrower) how can I put new pic or RA1/General unit in?

Share this post

Link to post

The difference (I'm guessing) would be that you don't have the delay start up and it helps support for the advancement for Tibed projects.


Koen or somebody who has encountered your second question would have to answer it. I really don't recall on anything like this. Even editing coding manually never had those errors.


Your cloned unit would use the same in game image, so you would see two seal icons. One should be the normal seal, the other should be the cloned unit.


http://forums.cncnz.com/viewtopic.php?t=3002 and some past threads have answers about adding new cameos to the game.

Share this post

Link to post

Well, I tried again, second question still there, those data mass ^^!. However, I can see new units now, the only problem is 2 weapon sound when I made things like "Mute Pistol" mixed by data from AWP and Pistol, or "Autosniper" by AKM and AWP(first AWP's voice, then AKM's).I'll try again( Already spent whole night lol).


There is a tech question. I'd like to have a Commando use gun when met Inf and rocket for tank/air/buildings(just try), is that I need to set the warhead for the gun as 0% dam to Unit and building armors?



still, do you know how to put new pic in game as icon? or how to take RA1/ General or other Mods' units in to my mod?



Oh, I just forgot: whenever I'm tring to save, it will tells me like this:"TIBOptimize info: Your mod is too big to be optimized. Optimization failed; attempting to use the Changes browser now will crash TibEd!" but I only made 4 units, 6 weapons and 3 warheads......how come those are too "big"?

Share this post

Link to post

I've tried about 10 times now.......once I can use different weapon for person and tanks, then lvl1&3 use C4 for building...but I entered game again without any thing changed, units has just changed! they no more use secondary weapons( even if the WH does 0% to tanks, they just keep shooting and never fire missile like last time). I really dono Y.


other problems on using secondary weapon: Helicopters use MG(setted to againest person armor only) firing eachother but do use missile to againest airplane( like AV 8); Also if I set a Inf. use double weapon and let it has the ability "has C-4 ability when elite" without put "yes" in Inf. board's "C-4" , then whenever I put mouse on building there's only C-4 sign but when unit goes near building, it won;t blow.


As the thing I understand, it might be the data problem....I mean, the Armor type setting. If we relord the original data from game, at Unit's armor space should be one in none/flak/Plate/Light/Mid/heavy/wood/steal/concrete or speacle_1&2.


But in fact it isn;t like the help data says: the data here is really a mass, GI armor=yes;

Boris armor=1;

attack dog armor=no;

Chrono Miner armor=no,

Giant Squid armor= true,

IFV armor="SparkSys,SmallGreySSys";

Mirage Tank armor= TankCrush;

Prism Tank armor= "100, 100, 275"



no doubt sometimes my new unit just stops there and won;t fire unless I tow it away and back after few sec......can anyone explain what are those different data means? they are totally not suit the offical explaination in Tibed itself.


Oh, anyone know how to keep dynamic visualize by cloning? I cloned siege cop. and new unit only stay in suspension without airscrew(totally no airscrew), but clones from NightHawk has their revolving airscrew...

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.