Jump to content

Shrike60

Members
  • Content count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Shrike60

  • Rank
    Recruit
  1. So, to get my modified units into the game I need to edit the map data for every mission?
  2. Well that is a bit confusing. If that is the case, why would the unit mods work on any of the missions if is is solely based on compiled maps already in the game? Trying to get me head around this.
  3. Version 1.08 was driving me off the deep end with all of the problems it has. I fell back to 1.07...much more stable and dependable.
  4. Ok...this is rather frustrating. The mods work fine in one mission then are completely ignored in the next mission. TW was never this difficult...lol.
  5. Ok...that actually worked (who would of thought it was case sensitive)...thanks for your help amigo.
  6. I added the prefix to all of the ModelConditionState tags for the NOD power plant xml. Eg... <ModelConditionState ParseCondStateType="PARSE_DEFAULT" PortraitImage="" ButtonImage="" RetainSubObjects="False"> <Model Name="W3DContainer:NBPOWER" ExtraMesh="False" /> </ModelConditionState> Compiled and took a look in the .big file and this is what I see: <ModelConditionState ParseCondStateType="PARSE_DEFAULT" PortraitImage="" ButtonImage="" RetainSubObjects="False"> <Model Name="NBPOWER" ExtraMesh="False" /> </ModelConditionState> Is W3DContainer: a directive or macro that does not show up in the built file?
  7. I dropped back to WrathEd 1.07 and the mod compiles with the units in the big file. Only a minor issue now - they are all invisible. The only change made was to cost of the unit. The game sees the cost change and builds the unit...it's just invisible.
  8. I noticed that the static xml is referencing Global.xml...but this file is nowhere to be found. There is a GlobalGameData.xml file.
  9. No joy. Same results.
  10. Hello All, Allow me to set the stage: Running Steam version of Kane's Wrath on a Windows 10 Box. Using WrathEd 1.08. Trying to modify the NODSaboteur. I extracted the xml data from CNC3EP1_english_1.2.SkuDef using WrathEd's Open SkuDef. My file structure is Mods\Nod\Data\. In the Data folder is the Static.xml file which contains... <?xml version="1.0" encoding="utf-8"?> <AssetDeclaration xmlns="uri:ea.com:eala:asset"> <!-- Main Mod File for Static Data --> <Includes> <!-- Reference to the Game's Global Data --> <Include type="reference" source="Global.xml" /> <!-- Includes of the Mod's Static Data --> <Include type="all" source="Static/NODSaboteur.xml" /> </Includes> </AssetDeclaration> ...and the Static folder that contains the NODSaboteur.xml file. I created a bat file with the following command line C:\WrathEd1.08\BuildMod.bat Nod 2.0 and run it as administrator. When I build, the files that are created are placed in C:\Users\Clay\Documents\Command & Conquer 3 Kane's Wrath\Mods\nod (created by the game itself). This is what shows up in it: I created several mods for TW and those files were a bit more than 1 kb...lol. As a sanity check I did a build of the sample mod. This was the results: The mods were not incorporated at all. Any advice would be appreciated.
×