Jump to content
Sign in to follow this  

Can anyone help ?!

Recommended Posts

Hi, so I purchased C&C Generals + Zero Hour on ebay and it just arrived...fancied a blast from the past. Loaded up the original generals and...


Everything ran smoothly in installation but when I try to boot it up I get the following message: Access Denied, need administrator privileges. I'm definitely on an admin account...


I've tried creating a new admin account and using that. I've tried going on properties and running as admin....really not sure what to do now and really, really want to play. Would be hugely appreciated if anyone had a fix for this, didn't know where else to ask for an old game like this. I'm on Windows 8.1 which apparently has encountered issues with running this game.

Share this post

Link to post

Hi there georgeparr,

I suspect your issue is related to your operating system and far from over when you fix this problem.
Win Vista -> Win 10 had a security update which disabled the SPTD required for Copy Protection.
Depending on your version of Generals / ZH (ie, I have the standalone Deluxe as well as T.F.D.) there are different cures or workarounds.
The error you're having this moment is easy, in the app Properties, turn off 'Run as Admin', then right click and Run as Admin.

Part two.one (lol): If you have TFD, use the update "tfd-103-rev4". After that, use Compatibility "Win XP SP2" on Generals.exe in both folders (Generals & ZH). Run the Apps from the TFD Launcher, Problem Solved.

Part two.two: Standalone Deluxe version, update Generals to 1.08 and ZH to 1.04 then find no-cd cracks for each as the SPTD cannot be bypassed (at this moment... SPTD2inst-v207-x64 installer does not function with current Win Vista -> 10). They still need the Generals.exe compat set to XP SP2.

Part Three: In My Documents find your game folders and add or edit the file options.ini changing it to this:
"AntiAliasing = 1
CampaignDifficulty = 2
GameSpyIPAddress =
Gamma = 50
IPAddress =
IdealStaticGameLOD = High
LanguageFilter = true
MusicVolume = 55
Resolution = 1024 768
SFX3DVolume = 79
SFXVolume = 71
ScrollFactor = 36
SendDelay = no
StaticGameLOD = High
UseAlternateMouse = no
VoiceVolume = 70
Settings can be changed again once you're in the game. (there was a runor that changing Resolution = 1024 768 to 1920 1024 works better, either worked for me... Oh and in ZH options.ini those settings are the same except Resolution = 1024x768 or 1920x1024 notice the 'X'.

That's all I know at this time and only because I've been on/off fighting these issues since upgrading to Win 10.

P.S. clean installs of all related programs and mods will really help... This means searching 'generals' in config after uninstalls to eliminate all mentions of C&C Generals. Careful not to delete references to the CD/DVD or unrelated applications. Then in Your Documents find your Generals & ZH data and (if like me) Change their names adding .Bak on the end so the folders are not removed but put aside for now.


Regards, Dak/AJ


Sources: http://www.daemonpro-help.com/en/problems_and_solutions/registry_and_sptd_problems.html describes how to remove current SPTD

http://duplexsecure.com/downloads download of newest SPTD (does not work with win 10 as of Dec 17, 2015

http://linustechtips.com/main/topic/425607-command-conquer-generals-universal-fix-thread/ More info specific to Generals and ZH


edit: I mentioned the options.ini file because I've, first hand, experienced a splash screen loading and complete drop to desktop with no error reported... changed the options.ini (created the file in a separate install) as directed and suddenly the game worked. So, more than once that fix worked for me. I hope it works for you all as well.

Edited by Dakados

Share this post

Link to post

You're bypassing the main issue instead of fixing it.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.