Jump to content
Sign in to follow this  

[SOLVED] Possible CNC-DDraw Rendering Glitch

Recommended Posts

Hello fellow fans of classic CNC,

I couldn't really find much about this topic, so I figure I would make a post in case anybody else has had this issue and come across a solution.

I am running the latest CNC95 1.06c r3* u4 standalone on Windows 10 x64. Everything seems to run fine, but after around 30-60 minutes of continuous game play (I'm playing the single-player campaign for context), I encounter strange behavior when accessing the pause menu (pressing ESC in-game) as well as any other in-game menu. When pressing escape to view the pause menu, my mouse cursor appears frozen and doesn't visibly move. I think this is a rendering issue because I can still access functionality such as the save dialog by memorizing the keystrokes I need to press to do said action and the pressing ESC again to return to the game, however there is no visual feedback in that the menu and mouse cursor remains static in the position it was in when I pressed escape to begin with.

The screen does perform an render update after successfully pressing enter to create a new save with (my new save game is shown in the save dialog window), but navigating the in-game menus is very difficult without any visual feedback on my cursor's position or the currently selected menu button. If I am able to return to the main menu and press exit by memorizing the proper keystroke combination to do so from, the game will stop responding, requiring me to forcefully end the process in task manager. Another interesting side effect is that after the onset of this erroneous game state, the game does not render the NOD obelisk's red laser (Obelisks still function correctly...very deadly ;), the red laser line segment just isn't drawn). And finally, during this game state, the videos fail to play. Only the first frame of the cutscene will appear, though the audio plays normally. Bear in mind that everything renders correctly and functions as intended before the onset of the erroneous game state.

My quick fix is to just try and save whatever mission I'm in the middle of when I first notice the rendering issues and and then force close the game. Restarting it resolves the issue until another 30-60 mins passes and rinse, wash, repeat. As you can probably tell, this is pretty annoying and immersion breaking. My research leads me to believe that this could be an issue with the particular combination of my PC hardware and/or OS settings and CNC-DDraw, although disabling CNC-DDraw in the config introduces a whole new set of graphical bugs (which are even more game breaking), so I keep it on. I've pretty much tried every single combination of config options to no avail. Anyone else experience this and find a solution? I've tried to spin up a WinXP (XP seems to be the earliest OS I can get the patched version to even work on as Win95/98 just explodes when tried) VM in VirtualBox and play that way but so far I'm getting horrible and erratic frame rates with the various settings I've tried though I've pumped system RAM up to 512 MB, VRAM to 128 MB, and enabled 2D and 3D graphics acceleration which should be more than enough. I welcome any suggestions for any successful system or VM configs that work well!

I just absolutely adore the original CNC because it introduced me to the RTS genre when I first played it on MS-DOS. Thanks to Nyerguds and your hard work, this amazing patch lets me relive my childhood. I've played both campaigns too many times to count but the replayability of this classic is limitless. Alright, I'll stop gushing now lol.

Thanks for your time!

EDIT: Found a solution! I replaced the version of CNC-DDraw included with the 1.06c patch with the newer version in active development found here: https://github.com/CnCNet/cnc-ddraw. The packaged CNC-DDraw apparently has compatibility issues with newer versions of Windows. I would suggest for the author to update the patch with this newer version of CNC-DDraw. All rendering problems described above are completely gone. No crashes either. Game functions like it was built natively for Windows 10. Make sure to edit your ddraw.ini if, for example, you have the fast scroll issue (Set a lower cap on maxgameticks) as CCConfig.exe has changed slightly. 

Edited by xvix9090

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.