Jump to content

amitakartok

Members
  • Content count

    4
  • Joined

  • Last visited

Everything posted by amitakartok

  1. amitakartok

    Various C&C errors

    Recently, I've gotten my hand on TD which I've never finished but decided to try. Problem is, I'm having an extremely annoying problem on my laptop; namely, an application error saying that an instruction on 0x6057fc60 can't read its own address. Both the error and the address are the exact same across TD, TS and RA2. On a freshly booted system, I can play for about half an hour before the error pops up and subsequent restarts of the games steadily decrease the average time until the next error to the point I once got an error after less than two minutes of gameplay. All three are fully patched with no mods, cracks, etc. TS and RA2 have Firestorm and YR installed and their ini files tweaked to run them at 1280x800. TD is set to Win95 compatibility mode; setting it to anything higher will display the error message out of focus so I can't even click OK but have to kill the process manually. Aside from this, Renegade is acting up too: bringing up the objectives screen and scrolling over any of the buttons at the bottom instantly exits to the desktop with no error message. The logfile in the Renegade folder is empty. Generals, TW and RA3 go flawlessly with no errors or crashes. What gives? I have no idea what's causing these. What it MIGHT be: 1. The application errors usually trigger when I scroll the map or something happens (giving orders is the most frequent culprit but it also popped up once when I put a building down in TD) so I suspect it could be a driver issue. 2. I have WinXP with a "tweaked" version of DX10 installed to get full throttle from my video card. It might be messing things up but TD's older than DirectX so it's unlikely. What it's NOT: I read about the trouble the MS Office Alternate Imput thingy causes for TD and uninstalled it. No change in the errors.
  2. amitakartok

    Various C&C errors

    OK, I applied Nyerguds' magic and TD no longer gives errors. Checked TS and it's already set to use W98 mode. However, I only saw the error once in TS so it might have been a one-off occasion (previous to that, TS ran for over an hour broken by an unrelated [i think] IE). I was trying to use widescreen because the screen gets too stretched horizontally. Plus 1280x800 is the maximum supported resolution of my display and is the native desktop resolution. RA2 still does around 70 FPS on that resolution, TS performs in the hundreds. Memtest could be problematic as my laptop doesn't have one of them ancient relics known as floppy drives. I could put the stuff on my external HD and try to boot from that. Not much point to it, though; I don't think the laptop's RAM can be swapped and I already looked around whether there's any way to tell Win to exclude a specified address from the RAM, no such luck. I also looked around in System Information and the hardware-reserved address spaces aren't even close to the affected one.
  3. amitakartok

    Various C&C errors

    I have XP SP3 but I wrote it above: if I set TD to Win98 compatibility mode, the error message appears out of focus (or to be more exact, it gives an out-of-focus error message and OKing that gives the same application error it does at Win95 mode) and alt-tab stops working so I'll have to kill the process via task manager. It won't stop the error from occuring in the first place.
  4. amitakartok

    Various C&C errors

    Original discs, no TFD. I'll look after those updates but the error's presence in both game engines suggests the problem is with my machine.
×