Jump to content
Nowaru

Pre-attack problem (Purifier)

Recommended Posts

Hi guys, I've got another question. :D

Now, with some editing to the purifier I wanted it to "charge up" its laser much like the obelisk cannon (I've made an alternative marked of kane beam cannon that does this already) but I'm having trouble with the flamethrower conflicting with the pre_attack states I use for the charging effect.

Basically, if the laser is firing at something outside of the flamethrower range, the pre-attack state works perfectly and shows the charging animation, but the moment someone gets too close to the flamethrower or you attack something nearby, only the charging sound is heard and no effects are seen. :/

I believe its to do with how the flamethrower is on a different weapon_set_update but I'm not sure what flags to use for that atm, I've tried user_8 and user_9 and WEAPONSLOTID_02 but to no avail.

I find it odd that the client sounds work perfectly but the model states don't. :P

Sorry about the extremely long code dump, I removed most of the unnecessary code for the purifier, but its still long as heck. >.> (I don't have any AudioEvent / Multisound stuff done yet since I've attempted this twice, but restarted out of frustration lol)

Also, to make matters somewhat more complex, I've got a modified the anti-infantry laser there as well. :S

Cheers. :) 

BlackHandCustomWarmech.txt

Edited by Nowaru
Upload was originally causing lag because of the huge amount of code. (XML)

Share this post


Link to post

I must to insist that you remove that code and upload your xml or use pastebin instead cause that giant script along with cncnz magic script just froze up 90% of my browsers on any type of device I'm use (it somehow work in chrome desktop version and in FF mobile version)

I assume it also why no one replied here till now but that just assumption xP

So... I sort of forgot what you explained there (and hell I'm not risking scrolling up from my phone to get it freezed again xD)

But if it was about purfires animations reacting to different ranges, I can assume it because the animations have different conditions (can't check atm) like weapon 1 fire condition and the like which will cause the laser animation to play only when weapon 1 is firing, the thrower also have its own cooldown/reload time as secondary weapon and may got prioritize by the game once it can attack.

 

I think the real issue may be that the purfire have some coded parts in it since the last times I messed with his voice I noticed he use lines that aren't even in its events and it also ignored any changed I did to its audio xml files

 

 

If it really coded you may need to make similar Xml and change all the IDs in it (sometimes it doesn't help either)

Edited by Egozi44

Share this post


Link to post
4 hours ago, Egozi44 said:

I must to insist that you remove that code and upload your xml or use pastebin instead cause that giant script along with cncnz magic script just froze up 90% of my browsers on any type of device I'm use (it somehow work in chrome desktop version and in FF mobile version)

I assume it also why no one replied here till now but that just assumption xP

So... I sort of forgot what you explained there (and hell I'm not risking scrolling up from my phone to get it freezed again xD)

But if it was about purfires animations reacting to different ranges, I can assume it because the animations have different conditions (can't check atm) like weapon 1 fire condition and the like which will cause the laser animation to play only when weapon 1 is firing, the thrower also have its own cooldown/reload time as secondary weapon and may got prioritize by the game once it can attack.

 

I think the real issue may be that the purfire have some coded parts in it since the last times I messed with his voice I noticed he use lines that aren't even in its events and it also ignored any changed I did to its audio xml files

 

 

If it really coded you may need to make similar Xml and change all the IDs in it (sometimes it doesn't help either)

Sorry, I never realised. 3:

I'm using Firefox Quantum on desktop, the only thing I noticed was the lag when I uploaded lol.

I uploaded a .txt file instead since it doesn't take XML. :3

Share this post


Link to post

I still hold to FF without Quantum cause I need my addons (which aren't being support anymore... really hate how Mozilla does that each half decade :/)

You can also upload it to pastebin which should let us see the xml as it is from separate link,

 

Btw if you have discord you could also try your luck on the c&c modding server since most of the modders are there (but that doesn't mean they always going to reply you since it depend on the weather and where the wind blow at that fateful day xP )

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×