Jump to content

Direct x8.1 error persists. Tried everything.

Recommended Posts

Hi. This is kind of a last resort as I don't know what else I can try.


I have the dreaded "directx 8.1, check you video card" (you know the one) error. I have scoured the internet and youtube to every "fix" video I can find. Tried them all, and nothing works. My laptop is a dell g5 5587, Intel I7 8th gen 8750H, GTX 1060 6GB, 16gb ram, windows 10 pro 1903, directx 12, screen resolution 3840x2160. The version of generals I have is the origin ultimate collection, but I have tried fixes on the downloaded version from oldgamesdownload.com just to make sure it wasn't the version at fault. Just to lay out a little bit what exactly I have tried.

1). The simple, and many a time quoted "deleting of the dbghelp.dll" out of both generals and zero hour folders. Still gives me the directx error.

2). Tried to create the options folder copy and pasting the templates from "fix" videos and web pages and saving it as options.ini into the generals directory in my documents. Then also changing the resolution to the same one as mine once that didn't work. Still get the error.

3). as suggested by generals legionnaire, checked that the folders which should appear in the my documents folder haven't unwittingly been put into microsoft one drive, it wasn't even set up, and the files were in my documents as they should.

4). starting from a fresh install, tried multiple different resolutions in the options.ini. Still gave directx error every time.

5). downloaded the official microsoft directx redistribution files to replace any missing directx folders should that have been the case. Still get directx error.

6). Starting from a fresh install again (to void fixes contradicting fixes, if that can happen), ran 2 fix packages. First a resolution fix package downloaded from www.computech21.com. still get the error. Second (again starting from a fresh install) followed the steps on this brilliant site (cncnz) step by step, installing the brilliant gen patcher and all its extras (hd package, gen tool etc). checked the files after, and all changes the gen patcher does I could see had been implemented, aswell as noticing the resolution change on the blue generals loading screen just before it pops up with the directx error and kills it. still get the error. Then (fresh install again) I also tried the gen patcher fixes after also downloading and installing the TUC launchers fix beforehand from moddb.com. Still get the error.

I have tried these fixes too in combinations, still no dice.

I really don't know what the problem is. All these helpful fixes that are getting other peoples generals working on windows 10 are just not touching mine it seems. Just what else could be wrong? I have never failed to get one of my all time favourite game series games working on my new laptop, even if it took patches and fan made fixes galore to do so. Is this really going to be the first one I will not get working? is there really nothing more to try? I'm pinning my hopes on one of you great people of this site being my saviour.


many thanks for reading.

Edited by w20adm

Share this post

Link to post

Have you rebooted the system after installing the missing DX9 files? They are installed in system-level directories and will only get properly loaded on bootup.

Share this post

Link to post

Well the laptop has been switched off/restarted multiple times since I Installed the dx R files. As over the last few days I have of course tried the above steps in my post over the several days as I learned of them. 


So yes I will have tried to run the game after reboot after install I'm sure. Still get error. And I'm pretty sure it was the correct download I installed, although if you could link me to where they are I can double check I downloaded the correct files.

Share this post

Link to post

I'm getting the impression it is unheard of for anyone's generals to not work after all the known fixes have been tried. Just my luck :(

Share this post

Link to post

Just to let you know, I solved this issue. I needed to paste the d3d8.dll file from dgvoodoo2 "MS" folder into the directory with the generals exe. It worked then. I had an issue with it crashing every time I alt-tabbed out, but once we knew what was needed to get it to run, I got sent a different d3d8.dll file from legionnaire generals via email. After replacing the old dll with the new it worked flawlessly. Can alt-tab in and out endlessly with no fear of crashes. Shout out to legionnaire generals, he knows his stuff. Thanks for the reply.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.