Jump to content
Sign in to follow this  

HELP - easy for you modders? (Shell Maps have been disabled)

Recommended Posts

I just did a fresh install of "The First Decade". I then patched it to the latest version. When I load either of the Generals games I don't get the "3D battle" (shell map) menu screens... only a static image. I also noticed that on my first load of each game EVERY graphics settings is turned off, putting me at the lowest possible settings for EVERYTHING. I'm able to then max all graphics settings out and save them... I can play the games and they play great, I then restarted the game but even though my settings are all maxed, still no shell maps "reat time 3D" menu screen.



Here's my system specs, maybe someone knows why this is happening???


Home Built PC:

-Asus P5N32-E SLI

-SLI setup with 2 EVGA 7950GT 512MB

-Intel Core2 Duo e4300

-4GB DDR2 RAM (800Mhz)


- Vista Ultimate 64bit


I've just done a fresh install of Vista (formatted and reinstall... NOT a restore of any kind). I have every current Vista update and I'm running all the latest Vista drivers for all my hardware (downloaded new driver sets yesterday).



It seems to me that when the game first loads it doesn't ID my drivers/hardware or doesn't find a match so they've decided that since they can't ID my hardware... it "must" be slow... so it defaults everything to the lowest possible setting. Of course I can change that, and they work... but I don't know how to get the title screen to show the shell map battles.


It's probably something easy to change too, like...

allowshellmap = yes/no.


Since I'm not a modder and I don't deal with all the possible INI settings I'm hoping someone here knows what I'm talking about.


Here are some pics to illustrate more.... like I said, the games are maxed on all settings and play fine.... it's just the main menu.



STATIC -- Here's my screen.... the menu works fine, but all I get is the non- motion picture.



In Realtime 3D Motion --...and here's a pic of how it should look.. and this is running on my old laptop, lol.




thanks for any ideas.

Share this post

Link to post

from my reading... the correct term is the "shell map".... so...


Both Generals and Zero Hour are not playing the "Shell Map" during the main menu in the back gound.


Maybe that will help anyone else trying to help me solve this.

Share this post

Link to post

Had the same problem on my old pc.

Reinstall = solved.


That's all I can say couse it's a pretty wierd situation..

Share this post

Link to post

Not that I want to do that... but at this point I'll try anything... will report back if the reinstall did anything... thanks.

Share this post

Link to post

tried to reinstall twice... no change.


Just to get everyone up to speed... this is everything I've done.


Modded the INI.big file... the "600mhz speed" thing I played with... no results. I've tried playing with the Options.ini... I've tried searching the registry... I've tried installing fan made shell maps... I've tried compatablity mode, I've tried some "admin" things... I think there are a few other things I've tried too, lol.



I think it has to do with my new hardware and or drivers... and/or because I'm running 64-bit OS/drivers. OR... for some reason my PC doesn't pass the games built in benchmark.


So... I see 4 ways of fixing this... either disabling the hardware check/benchmark so that the test isn't run.


add some more hardware info into the game so it can "ID" my stuff... I see a list for P3 P4 K7 etc... also a list of video cards. If someone can tell me how to add a Core 2 Duo and an nVidia 7950GT to that list that'd be great.


Enter a fake benchmark result number making the game think my PC benched more than it did... which it should anyway.


find the entry that enables/disables shell maps and force a change... maybe something like the -noshellmap switch for the shortcut.



Thanks again for any help,


Share this post

Link to post

the worst is that it's TFD, so patching it won't help.


Try downloading a new graphics driver, or update it.


Sometimes virus protection programs seem to interfeer with games also. try and check that.

Share this post

Link to post

thanks for the ideas...


I'm running the latest nVidia graphics driver... and I've tried turning off my Norton AV... no good.



I do have an original Generals and Zero Hour around here somewhere.... if i can find them I'll uninstall TFD and install the regular versions and see if that changes anything.

Share this post

Link to post

More than likely, your problem Vista, not the game or your hardware. I run a near identical set up and everything plays fine. I suggest 'upgrading' to XP or running Generals/Zero Hour in administrator mode.

Share this post

Link to post
or running Generals/Zero Hour in administrator mode.


Well.. He should have done that in the first place..

Share this post

Link to post

I've already been running in Admin mode... I can't "upgrade" to XP as you say because I'm running 4GB of RAM and 32bit XP won't support that.

Share this post

Link to post

So get 64-bit XP. It does exist, you know.


Outside of those two things, I'd say you're pretty much screwed, but honestly, does it matter that much? So long as the game plays, I'd say you're good.

Share this post

Link to post

Sure there's 64bit XP, but driver support under 64bit XP isn't as good as 64bit Vista


No, it's not that big of a deal since the games do run... but I like to use fan made shell maps and radomizers so that is a problem.


Also.... one day, you'll be using Vista as well and you'll be right were I am so I would think it would be best to find a solution now than wait until there are 40 posts about this in a year.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.