Jump to content
Sign in to follow this  
hellfire12345

RA3 Issue with Nvidia Optimus?

Recommended Posts

Hi,

 

just got RA3/uprising off steam but the problem is it fails to run on my dedicated Nvidia 420M GPU and instead runs on the integrated intel gfx.i have added the executable file (C:\Program Files (x86)\Steam\steamapps\common\Command and Conquer Red Alert 3 Uprising\ra3ep1) to the nvidia whitelist but still its running on the integrated graphics. My laptop is a Dell XPS L501x and nvidia driver version is 275.33 (runs starcraft 2 flawlessly) ...HELP ME PLEASE!

 

ps: big fan of all c&c and longtime reader of cncnz

Share this post


Link to post
Share on other sites
Plokite_Wolf    144

Are you sure it's the problem with your graphics card? It would be really helpful if you could tell us your configuration.

Share this post


Link to post
Share on other sites

Im using a Dell XPS 15 (L501X), has Intel Core i5 2.53 GHz, 4GB RAM, windows 7 64-bit and Nvidia 420M GPU...

 

basically when im not playing a game or doing a graphics intensive acitivity, the GPU shuts down to conserve power, and the integrated graphics chipset kicks in...as soon as I turn on some graphics intensive application like starcraft 2, the GPU becomes active

 

the problem is that in the case of RA3 Uprising, that doesnt happen and it tries to run the game on the integrated graphics instead of the GPU. Also when i look at the GPU activity meter, it doenot show any GPU usage which confirms this....ive tried a few workarounds on the internet but they dont seem to work

Share this post


Link to post
Share on other sites

ok, so i figured some things while looking through some forums, but was too busy to come back here and post cuz havin so much fun :)

 

one thing is for sure though, its a bug in the Nvidia Optimus software, specifically affecting laptops.

 

so here are a few solutions that might work:

 

(a) set your GPU as the default gfx adapter (at the cost of higher power consumption in idle/desktop mode)

(b ) use the "extended desktop" feature with the secondary monitor set to the GPU (this fools the system into believing it is running on the default but does not apparently work all the time)

(c ) right click on the exe of the game and select "run through high performance Nvidia processer" (but you will have to do that every time you play it)

 

Hope this helps anyone having the same problem.

Edited by hellfire12345

Share this post


Link to post
Share on other sites
eXonius    0

I know this thread is old but I had the same problem today, that Red Alert 3 would only run from the integrated graphics instead of the Nvidia card, so just in case someone else have this problem too.

 

The problem is that the 3D profile settings in Nvidia expects the file "ra3_1.12.game" to end with .exe, but it does not. So to fix it I used the Geforce 3D Profile Manager (http://www.geeks3d.com/20100528/manage-your-sli-profiles-with-nvidia-geforce-sli-profile-tool/) to import a txt file with the settings, then changed a line in the profile that looks like this:

 

Profile "Command and Conquer: Red Alert 3"
ShowOn GeForce
ProfileType Application
Executable "ra3_1.10.game.exe"
Executable "ra3_1.5.game.exe"
Executable "ra3_1.11.game.exe"
Executable "ra3_1.8.game.exe"
Executable "ra3_1.12.game.exe"
Executable "ra3_1.2.game.exe"
Executable "a3_1.7.game.exe"
Executable "ra3_1.0.game.exe"
Executable "ra3_1.7.game.exe"
Executable "ra3_1.4.game.exe"
Executable "ra3_1.9.game.exe"
Executable "ra3_1.3.game.exe"
Executable "ra3_version.game.exe"
Executable "ra3game.dat.exe"
Executable "ra3_1.1.game.exe"
Executable "ra3_1.6.game.exe"
Executable "ra3.exe"
Setting ID_0x00d55f7d = 0x20000000
Setting ID_0x1033cec1 = 0x00000003
Setting ID_0x1033dcd2 = 0x00000004
Setting ID_0x106d5cff = 0x00000000
Setting ID_0x1095def8 = 0x02800205
Setting ID_0x10f9dc81 = 0x00000011
Setting ID_0x10f9dc84 = 0x00000200
EndProfile
To this:
Profile "Command and Conquer: Red Alert 3"
ShowOn GeForce
ProfileType Application
Executable "ra3_1.10.game.exe"
Executable "ra3_1.5.game.exe"
Executable "ra3_1.11.game.exe"
Executable "ra3_1.8.game.exe"
Executable "ra3_1.12.game"
Executable "ra3_1.2.game.exe"
Executable "a3_1.7.game.exe"
Executable "ra3_1.0.game.exe"
Executable "ra3_1.7.game.exe"
Executable "ra3_1.4.game.exe"
Executable "ra3_1.9.game.exe"
Executable "ra3_1.3.game.exe"
Executable "ra3_version.game.exe"
Executable "ra3game.dat.exe"
Executable "ra3_1.1.game.exe"
Executable "ra3_1.6.game.exe"
Executable "ra3.exe"
Setting ID_0x00d55f7d = 0x20000000
Setting ID_0x1033cec1 = 0x00000003
Setting ID_0x1033dcd2 = 0x00000004
Setting ID_0x106d5cff = 0x00000000
Setting ID_0x1095def8 = 0x02800205
Setting ID_0x10f9dc81 = 0x00000011
Setting ID_0x10f9dc84 = 0x00000200
EndProfile

 

Simply changed from "Executable "ra3_1.12.game.exe" to "Executable "ra3_1.12.game". Then imported the modified txt file again with Geforce 3D profile manager.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×