Jump to content
We see you're using an ad blocker of some kind. And hey, that's okay! Some of us do, too! We just want you to know
that we don't use conventional spammy ads at CNCNZ.com. We only link to our own internal projects, or other sites
within the Command & Conquer community! Who knows, you might see a mod or download you like! Thanks!
Sign in to follow this  

missing audio and buildmod crashing

Recommended Posts

the only link I can find from google that'd answer this question I keep getting a 401 on so I'm asking here


I copied the warfactory, st harvester, z harvester, changed a few values.. nothing major, just the health, build radius, costs, then compiled mod


1) no sound from the war factory, at all. Not during the rise animation, nothing.

2) all 3 harvesters are buildable from the war factory, only the gdi harvester has any sound. The ST and Z are completely silent. No "let's get to that tib zone".. nothing.


Everything else I've copied and modified has worked. So what happens to the audio? I've seen [asset not found] in the coding, but its like that in the core files where I got it from.


A side note: build.bat from WE 1.07 gamma, it would delete the libmpg123.dll file after a few uses, which would give an error. i'd get the lib file from the zip and put it back. Eventually it quit working altogether--crashing right at the start--and I would have to get the 3 .bat files and the Tools folder , delete the current ones then drag n drop from the zip back to the mod sdk folder. It would work, but after every few times, it would begin crashing right at the start if it didnt delete the .dll file.


I hunted down WE 1.08 gamma, replaced all of the files, and it works more than it fails, but when it fails I just get the same files (batch and Tools folder), copy it all over, and then it works again like it should.


I've also noted that not all builds are the same. I cannibalized the sample mod because I really like the mirage tank, but sometimes when I build the mod, the sound is included. The mirage tank can talk. But..... Sometimes it does. Sometimes it doesn't.

Share this post

Link to post
Share on other sites

What the hell are you doing with your SDK folder? I never heard that WrathEd deletes something from the tools folder. Oo

Also if you extract something from the game, load the skudef file, not a single big. That should avoid the "Asset not found" part. And see the documentation regarding sound assets. Menu entry: XML Assets. Paragraphs: Asset References and Pipeline Object IDs.

The sample mod works pretty good in any cases.

Edited by Bibber

Share this post

Link to post
Share on other sites

I unzipped the entire 1.07 mod sdk as it is. Ran the buildmod a few times. Last night it was giving the error that the one .dll was missing. I went back to the zip, got the dll, put it back in the tools folder. I watched it. Window open, eyes locked on it. Third time I ran buildmod, the dll disappeared then it crashed. Since I updated everything to 1.08, it hasn't done it yet. I checked the history for MS Security Essentials and Malwarebytes, it didn't show in either. Its possible one or the other got rid of the dll. I use a third anti-v/m but it hasn't been on in a couple days.


The only thing I'm playing with are adding files to the sample mod folder then editing them by copying the xml data out of the core big. This is incredibly tedious too. Simple, but really tedious. I'm rearranging existing things. To me, the orca sensor pods upgrade should be on the GDI Air Tower, not at the Command Post. Things like that. I'd like to add the super sonic jet from the support power as a buildable unit at the air field, and the Ox too with more slots. But that will be after I'm done with my arranging and editing.


I haven't played CnC4, is the mirage tank from there?


Thanks for the tip about the skudef. I knew I'd seen the references before, but couldn't remember which file it was. I'll revisit the documentation too to see if I can piece this together tonight.

Share this post

Link to post
Share on other sites

Mirage tank is from Red alert 3

You may noticed it not always say some lines due to bibber (I assume?) forgot to add a few of them to the right conditions (I noticed it and fix it year ago) :3



The sound issue you have in your xmls is known in ver 1.07, it because it extract the audio lines incorrect or not find them at all


The libmpg123.dll is issue that also happens to Zypherbullet, don't sure what causing it but I know it never happened to me with the versions I uses, and I use the same builds for almost three years by now,

that why I and few other modders decided to use mixed versions and not relay on ver 1.08 gamma nor 1.07 alone xD


(If you have win10 it may be the cause though)


1.07 can be good to extract xml with full code lines but it can fail you mostly in the sound section


1.08 gamma not support sounds unlike it's buggy progenitor ( 1.08 not gamma )


And don't work with some changes at all (while 1.07 and buggy ver of 1.08 does)


I recommand you use 1.08 buggy ver for compline the mod files, and 1.07 for the xmls, if you dk how to fix the sound lines either take a look on the same xml with 1.08 buggy, or just use 1.08 buggy most of the times since WED will add what it miss upon complining (from what it seem)


You probably will prefer 1.07 for the xmls though... just be sure to look for broken lines and fix them before you use them


1.08 buggy can help you detect the broken lines with it's xmls if you view them via browser like IE or FF


You can get it with the other random versions I uploaded here




(I think it the fifth time I gave it to someone this week by now xD )

Edited by Egozi44
  • Upvote 1

Share this post

Link to post
Share on other sites

I got a junk mb and need a new one... your head would spin if I explained to you what happened to it. In my dealing with, a strange event happened. My cat tried to rub on it a couple weeks back and knocked it off my nightstand, much to his cussing, which bsod it immediately but since then I've only had 2 mb failures. Before that there'd be a mb failure anywhere from boot til it happened. 5 minutes, 5 hours, who knows, which made is nearly impossible to do anything.


well, long and short of tonight is +2 thanks for pointing me in the right direction. I hadn't looked at the skudef in over a week and forgot there was more info in there. I was looking for a manifest file with the audio listed in it and you helped me connect the two. Naturally, I feel pretty stupid, but these are rookie mistakes for a rookie on this version of this game. I've managed to fill in all the missing info. Not only are the sounds all back, but I fixed all the id="#####" ones too. Tedious... sooo tedious, but theoretically worth it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this