Jump to content
Sign in to follow this  
Guest Guest

TibEd v1.6 Suddenly Runs Extremely Slow -->

Recommended Posts

Guest Guest

Hi all,


Just needed to drop in real quick cuz I had been using TibEd to do stuff with Tiberian Sun & Firestorm, and it worked like a charm, but now that I installed Red Alert 2 (w/o Yuri) and am trying to edit that, all of a sudden TibEd itself takes like 30 seconds just to get from the main choose-which-game-to-edit screen to the actual RA2 INI's main editing page. Now, TibEd initially has the Allied Attack Dog highlighted, and when I select the next Infantry unit below it, it takes a solid 5 or 6 seconds to actually change the displayed pic and variables for editing. When I was editing TS&FS, it initially would load up in about 2 seconds, and the switch between units/items was instantaneous.


Has anyone else experienced this? I tried uninstalling/reinstalling TibEd, but that did not make a difference. Also, I remember within a couple months of RA2 being released that I was editing it with TibEd and have no memory of it being this "laggy" or whatever.


Any ideas?


Thanks in advance. Hope everyone is as well as can be.


~Damien Thorn, a.k.a. "Guest" =)

Share this post

Link to post

Defrag your computer's hard drive. I don't know what program's you have for it, but that alone helps speed things up. Especially when you've just deleted a bunch of junk.


Also, unless you've payed for it, TibEd has an automatic ten second delay after you've ahd it for thirty days. That would explain some of the delay in starting it up. Registering TibEd may help. All it'll cost is about ten dollars.


If disk defrag doesn't work, you may want to invest in a new computer. Just make sure and back up any important documents before you junk the old computer.


And the simplest of all... Just use the raw *.ini files. All you need is something like WordPad or even just Word. You can accomplish more with the raw *.ini than through TibEd, considering the size of some of the groups. Also, this will allow you to get a feel for the *.ini files so you can edit the AI.INI, which allows you to get the AI to build your new units. The raw *.ini codes only lag will be how long it takes your computer to open them.

Share this post

Link to post

This is not the TibEd shareware kicking in, trust me.

Which Windows are you using? If it's 98 or ME, then you should try to close other program running in the background/system tray.

If its Windows XP, then there should not be any problems... as long as you have enough RAM.

Share this post

Link to post
Guest Guest

Thank you for the ideas and advice. I actually gave up on it and meant to come back here to explain sooner. Anyway, to respond to your comments:


1. Defrag: I am the most "anal" person you will ever know when it comes to defragging their hard drive(s) =) So that is not a concern.


2. I did indeed pay for it, I don't remember when exactly, but I do remember it was the same day that I first downloaded it to see what it was like -- Great work, Koen =). So that, too, is not a concern.


3. Not sure if a new computer would make any difference, as my current system is a Falcon Northwest-made AMD Athlon Thunderbird 1.4GHz, with 768MB of PC2100 DDR-SDRAM, a GeForce3 64MB video card, and an 80GB 7200RPM 8MB cache hard drive, etc etc. I would like to think that, considering it worked like a charm on 2 previous C&C games I was editing, RA2 editing wouldn't require my system to be so much more beefy.


On a side note, I actually did order a new computer from Alienware a couple weeks ago, and it is scheduled to be delivered c/o FedEx by tomorrow! Hurrah! ;-)


I did end up editing the rules.ini file manually in the end, and I had forgotten just how messy that damn file is. **


Koen: I'm using WinXP SP-1 Pro, and have 768MB of RAM as stated above, so that is also no worries.


OK so get this. Now that I have responded to the ideas/questions you guys had, allow me to explain what I experienced when I actually tried to play RA2 itself (I had originally installed RA2 and patched it to v1.006 but then wanted to just change a couple things before even loading up to watch the intro movie, at which point I had the slow-downs and came here to post my question). Shortly after my initial post, I went to play RA2 in it's "clean" form. First thing I noticed that was odd: Between the time the RA2 loading screen shows up (just over the desktop, not the in-game loading screen) and the time the intro movie played, like a full minute or two went by. Then when the actual in-game Main Menu appeared for me, the music was playing and everything seemed normal, except that the title bar that says "Main Menu" and the button labels, along with the radar-image thing in the background of the screen, seemed to have frozen for a solid 2 - 3 seconds before they finally showed up. So my mouse was moving and like I said it all seemed normal except for that odd text delay. This same delay occurs every time I click on a tab (Single Player, Multiplayer, et al) for a sub-menu.


Hopefully I made enough sense in that previous paragraph's attempted description of the issue to get an idea of the delay that was happening.


Now, when the movies are playing, they are totally fine, no stutter or anything. However, when playing each mission, every single time EVA is about to say something, the entire game, except for my mouse, freezes for 2 - 3 seconds! I'll be moving Tanya around to blow up the ships in the first moments of the Allied campaign, but the game will otherwise totally freeze (except for the mouse, which still moves around without delay) when EVA is about to say "Sir they are attacking the Statue of Liberty" etc etc. Once she starts to talk, the game un-freezes and plays as normal. Then, after I beat up the Soviets on the dock, the Statue of Liberty gets destroyed and EVA says "Incoming Transmission", and I know exactly when she is going to say it, as the game freezes for 2 - 3 seconds. Then the Soviet leader guy does his in-game movie speech about joining the Soviets and all that, and that in-game video plays just fine, as well as the actual gameplay that is going on while the video is playing.


That pattern continued so that every single time EVA was about to say something - whether it be a scripted event heads-up kind of thing, or just to say "Building", "Building Complete", "Training", "Unit Ready", etc etc - the entire game would freeze for 2 - 3 seconds.


Oh, during this entire time, the background music has been playing, and like the movies, it doesn't skip or stutter or anything.


You can probably imagine how frustrating it was getting, as EVA has a lot to say in that first "intro-ish" mission. Then in between the missions, the score screen and videos that play all work fine and dandy.


About halfway through mission 2, I quit, then uninstalled the game and everything, thinking something must have gotten corrupted.


But then I tried TibEd again after I had uninstalled RA2, and TibEd worked just fine again! No speed hiccups or anything. That reinforced my thinking that something in RA2 itself was corrupted, so I calmed down and then, after a quick regclean and a reboot, reinstalled and patched RA2.


So, with a clean install and patching as such, I decided to just launch the game without having TibEd try to edit anything, thinking maybe the game needed to run once before being edited, else the stutter thing happen again. So there I am, all confident that I had the ball, when I realize that the Main Menu (and sub-menus) were doing that 2 - 3 seconds delay thing, and with my hopes and dreams of it working properly just about shattered, I launched the Allied campaign, started to ruin the Soviets, and then gameplay froze for 2 - 3 seconds before EVA started to talk.




So now I am at a point trying to think of how this current system setup of mine is any different than it was a year ago when RA2 & Yuri ran just fine, and TibEd edited them with no worries. The only thing I can think of is that I converted from FAT32, which I had been using for years, to NTFS, as of about 2 months ago.


Has anyone been able to play RA2 on a system using the NTFS?


I've tried the usual EA/Westwood suggestions to get it to work, like having it use Win95 and Win98/ME compatibility mode, etc. But as of now, I was so bummed out that I just uninstalled everything and said to hell with it. I had been on a bit of a C&C binge on this machine, replaying through C&C95/CovertOps, RedAlert/CounterStrike/Aftermath, TibSun/Firestorm, and was now on RA2, in preparation for my Alienware behemoth arriving and thus enabling me to play Generals/ZeroHour properly (on this system I have to disable just about everything in the custom settings options menu, as the game has a bit of artifacts/choppiness issues otherwise.)


Anyway. Sorry this post is like 15710385 pages, but thanks again for tryin to help me out. Take care =)


~DamienThorn, a.k.a "Guest"

Share this post

Link to post
Guest Guest

Oops, I meant to have a bit of a "P.S." at the bottom of my previous post regarding the "**" notice I had put in. Koen, I had a question (unrelated to the issues above, hence the **) regarding the rules.ini-type files and the massive amount of comments they contain, and an option within TibEd, in the Preferences menu. You can choose to optimize the files, which filters out all comments, or the other, "old" way, of smaller files but slow with bigger changes. I always selected the optimize checkbox, as I thought it would get rid of the thousands of "; ..." comments in the ini's, but I've never been able to really figure out what they do (as it doesn't do what I thought it might do).


What do those two options do?


Thanks again, and keep up the great work =)


~DamienThorn, a.k.a. "Guest"

Share this post

Link to post

Sounds like your CPU is maxing out. Go to your task manger and see what all is running. The movies are run off the disk, whereas everythng Eva says is saved onto your computer. If you have, say, a virus scan running in the background, you'll experiance horrible lag.


You may have nabbed yourself a virus, worm, or trojan out there in the cold reaches of cyber space. I'm no tekkie, so everything I say is merely speculation. Always worth a try though.


The first thing you should try though is what Koen said, and make sure nothing is running in the background that doesn't need to be.


Hope you can get it running.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.