Jump to content
Sign in to follow this  
dodgevipergts

C&c 3 Real Bad Lag

Recommended Posts

you may have heard about the bug in C&C Generals Zero Hour where you'd play for 15 minutes or so then mega lag something to do with a memory leak i think and EA could never be arssed to fix it this happend to me and it annoyed me so i got C&C 3 insted i played it for like 2 years then one day i decided to Zero Hour Agein still same old mega lag so then i thought **** this slinged Zero Hour across the room and slammed in C&C 3 i played a skirmish ageist 1 AI in a small map and after 15 minutes it started to lag badly much like in ZH so i downloaded Catchman to check the RAM usage it looked pretty bad like it was using 100mbs in a matter of minutes slowly getting slowwer and slowwer intill the lag was unbearable so i think it must be a memory leak (but not sure) i've tryed reinstalling about 5 times no success tryed lowering the graphics from low (my comps not that fast) to very low but nothing works i hope someone can help me out here the strange thing is i played it for years with no lag and then all of asudden it lags cheers in advance

 

(it also lags in Campains don't know about in online play)

 

Windows 7 Home Edition 64 bit

Free Hard Disk: 158.5 GB

RAM: 2 GB

Processor: Mobile Intel® 4 Series Express Chipset Family

CPU: Celeron® Dual-Core CPU T3000 @ 1.80GHz

 

(i know it's not that powerful but the game normally runs just fine)

Edited by Sonic

Share this post


Link to post
Share on other sites

Games use ram so the more you have the better things will be. But from the looks of your system specs you have an onboard video card, that's why C&C3 lags for you. Plus a Celeron CPU is not good either, especially for gaming.

Share this post


Link to post
Share on other sites

Games use ram so the more you have the better things will be. But from the looks of your system specs you have an onboard video card, that's why C&C3 lags for you. Plus a Celeron CPU is not good either, especially for gaming.

yeah i get what you mean but i have been playing it for years and have played loads of other high powerd games on my laptop before with no lag like driver parrel lines, half life 2 (in ultra graphics and no lag for some strange reason) and red alert 3

Share this post


Link to post
Share on other sites

I used a 1.8 gHz dual core and played it fine. Then again, I had a lot more RAM and a dedicated video device. Seems to me the culprit is partially a lack of RAM and an integrated video device, but I think that was noted. Updated drivers might help if they're not already there.

Share this post


Link to post
Share on other sites

Yes, but Vista and 7 need 2.2 GHz at least (XP needs 2.0). Other than the CPU, it should run fluently on Medium details at least.

 

Also, I think it's necessary to mention that C&C 3 was made for nVidia cards. My ATi Radeon X1550 lags like hell on High and Very High. Sometimes it even overheats fully.

Share this post


Link to post
Share on other sites
Yes, but Vista and 7 need 2.2 GHz at least (XP needs 2.0). Other than the CPU, it should run fluently on Medium details at least.

I don't even have a 2.2 gHz CPU and I can play TW on max without an issue.

 

Also, I think it's necessary to mention that C&C 3 was made for nVidia cards. My ATi Radeon X1550 lags like hell on High and Very High. Sometimes it even overheats fully.

Either your drivers are out of date or that card can't handle the strain that high/very high puts on it.

Share this post


Link to post
Share on other sites

I don't even have a 2.2 gHz CPU and I can play TW on max without an issue.

 

 

Either your drivers are out of date or that card can't handle the strain that high/very high puts on it.

i play the game on low like i said the lag seems to be like the dreaded ZH lag where it would lag in skirmish because of bad coding and memory leak but i don't think it's the coding since it used to work i have patched C&C3 recently

Share this post


Link to post
Share on other sites

ZH doesn't lag that badly until you have more than a handful of AIs on the same map. The pathfinding is awful, but there's no real memory leak associated with ZH, or TW.

Share this post


Link to post
Share on other sites

Any idea on reducing LAG in Network/Online games of CnC3?

I get a lot of LAG in Online, I don't mind slow, just not Block-Like.

Share this post


Link to post
Share on other sites

Any idea on reducing LAG in Network/Online games of CnC3?

I get a lot of LAG in Online, I don't mind slow, just not Block-Like.

 

http://portforward.com/english/applications/port_forwarding/Command_and_Conquer_3_Tiberian_Wars/default.htm

 

Find your router (or just open Windows Firewall to edit): http://windows.microsoft.com/en-us/windows/open-port-windows-firewall#1TC=windows-7

 

In 1st link you'll find ports needed to be opened for online play. I am not sure is still valid due to closed GameSpy servers, but in game files should still require those ports for smooth play.

Share this post


Link to post
Share on other sites

AFAIK, if you don't open the necessary ports, you can't even connect to anybody, so that's not the problem. C&C:Online should use the same ports GameSpy did.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×