Jump to content
chimekolover

Can't run The First Decade properly on Windows 10

Recommended Posts

Tiberian Dawn, Red Alert, and Red Alert 2 have been patched already and work perfectly. and I have run the compatibility settings for Generals and Zero hour but nothing works. I'll try the .ini files in each but idk if that will work. my desktop should support the resolution. It can even put out in 4k. I'll try the Tiberian Sun patch see if that works.

Share this post


Link to post

I managed to get Generals and Zero Hour to run but Tiberian Sun still wont play cutscenes same with Firestorm. I had been using that patch for them already.

Share this post


Link to post

Back again. After a bad bit of advice from a Microsoft technician on fixing an issue with my desktop I had to reinstall every single game I had. I followed all directions on here to patch The First Decade and got most of the games running fine. The games still giving me trouble are Firestorm, Red Alert 2 and Yuri's Revenge. Firestorm loads and goes to the menu and I am able to start a campaign but it just goes straight to the load screen and says "unable to read scenario!". for RA2 I applied multiple patches and got rid of the black screen issue but as it gets to the main menu it freezes. no options load, cant move the mouse but the music still plays. for YR when i try to start the game I get an error saying the application cant start correctly with the code 0xc0000142. for Firestorm's issue I looked everywhere but no one seems to know how to fix it.

Share this post


Link to post

Try installing the CnCNet installer for YR online play. It has a bunch of automatic compatibility fixes.

Share this post


Link to post

Ok, after a full uninstall and reinstall of The First Decade I tried something different and didnt apply TFD Unofficial patch. doing so I applied quick fixes to Red Alert to play the Soviet movies using a RA Launcher, got Tiberian Sun and Firestorm to work using an installer and patcher, got Renegade to work by installing a patch, and installed a patch to Red Alert 2 to fix a black screen issue. The unofficial patch may have done more harm than good in my case. The ONLY game that wont work is Yuri's Revenge now. I click on it to load and it looks like it will start but after a few seconds it just goes back to the desktop with no error message. I tried compatibility settings but nothing seems to work. any ideas?

Share this post


Link to post
4 hours ago, chimekolover said:

Ok, after a full uninstall and reinstall of The First Decade I tried something different and didnt apply TFD Unofficial patch. doing so I applied quick fixes to Red Alert to play the Soviet movies using a RA Launcher, got Tiberian Sun and Firestorm to work using an installer and patcher, got Renegade to work by installing a patch, and installed a patch to Red Alert 2 to fix a black screen issue. The unofficial patch may have done more harm than good in my case. The ONLY game that wont work is Yuri's Revenge now. I click on it to load and it looks like it will start but after a few seconds it just goes back to the desktop with no error message. I tried compatibility settings but nothing seems to work. any ideas?

See the "Handling Red Alert 2 and Yuri's Revenge on Windows 8/8.1/10" section in this guide: http://www.cncnz.com/features/technical-support-help-guides/installing-command-conquer-red-alert-2-yuris-revenge/

Share this post


Link to post

I actually got it. I applied the patch and some compatibility settings to all YR executibles and it works just fine now. seems the problems are from that patch for the full collection on Windows 10.

Share this post


Link to post

Can someone help me?

 

I installed TFD and the game (C&C95) was already at version 1.04 rev a. The mouse pointer was working normally and I could select anything from main menu.

 

Then I realized from here there is a 1.06c rev 3 and then I installed it. Now the mouse pointer only appears stuck on four corners of the screen. I cant select anything anymore. In cctools there is an option there about mouse but didnt fix it.

 

Any idea?

Share this post


Link to post

What do you mean with "the mouse pointer only appears stuck on four corners of the screen"? You only see the mouse pointer at the corners of the screen?

Share this post


Link to post

It looks like that ddraw ini, some mouse sensitivity parameters there.

 

I fixed it but now on mission 1 I get duplicate screen (I play in full screen). 

 

here is the pic: 

 

how to solve this?

M5Dw9Y5.jpg

Edited by pbsk8

Share this post


Link to post

That happens because the resolution you have chosen is larger than the map itself. Just open and close the options menu and the duplicate will go away leaving a black screen.

  • Upvote 1

Share this post


Link to post

So I've downloaded the tfd-103-rev4.exe and ran it, I did not install the cnc thing at the end. My biggest concern was command and conquer generals/Zero Hour as they were my favorite however it was telling me to insert the disc but now after the patch it simply wont load. I get the screen like it's trying to load the game however that eventually goes away and the launcher reopens.

Share this post


Link to post
17 minutes ago, Sir_BlargsAlot said:

I did not install the cnc thing at the end.

Whatever the hell do you mean by this?

 

17 minutes ago, Sir_BlargsAlot said:

it was telling me to insert the disc but now after the patch it simply wont load

Apparently, you ran neither The First Decade setup, nor the 1.03 rev4 patch, nor the game itself as administrator.

Share this post


Link to post

the image is what I mean by cnc thing. Sorry for the lack of knowledge on the subject but this is my first time dealing with patches or any outside fixes for games since I primarily play on Xbox. Also when you say run as admin I am assuming I am wrong in the belief that being the admin user automatically does this?

Capture.PNG

Share this post


Link to post
23 hours ago, Sir_BlargsAlot said:

cnc thing

This is still the most vague definition of anything that I've seen on the Internet. C&C stands for Command & Conquer, as in the entire series, so you couldn't be more vague if you fucking tried.

 

23 hours ago, Sir_BlargsAlot said:

Also when you say run as admin I am assuming I am wrong in the belief that being the admin user automatically does this?

Yes.

https://www.digitalcitizen.life/how-run-programs-administrator-windows-7

Share this post


Link to post

yes well clearly you either decided not to read my second post where I showed a picture of what I am talking about or you just wanted to be a troll, regardless I figured out how to run as an admin on my own and uninstalled everything to start over and now instead of generals just not starting it gives me the serious error message that talks about there may be a virous or overheated hardware.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×