Jump to content

Crash research

Recommended Posts

10 hours ago, Lethe said:

Caused by running this patch under windows 8.1 with windows 95 compatibility mode enabled with default settings

You're not supposed to do that.

Share this post

Link to post

That's weird, since the patch is what enabled that compatibility mode in the first place.  Also changing any setting with CCConfig.exe re-enables compatibility mode.

Share this post

Link to post

The required compatibility modes differ widely depending on the system, but I never got an accurate list of which modes work best on which systems, so yes, it is entirely possible there are still errors in what is activated by the tool / patch. Thank you for this new information.

Could you test what works best in general, to both get the game running and not get any graphics freezes in the map animations and in-game menu? I don't have a Win8.1 PC.

Share this post

Link to post

I run a Windows 10 machine. I run cnc95 gold free with 1.06 latest revision. I was able to play till GDI level 10 without a crash.  The first time it died it said instruction at  004ce54b  reference memory at 00051ed2.  The second time it errored it’s said 004ce54b reference memory at 0002d27b. 

Share this post

Link to post

Well, that's the same address (004ce54b) both times. As I said, something with drawing. The second value is rarely relevant since the crash itself means that the value referenced at that moment was corrupted. Knowing the corrupted value is sadly never any kind of indication on how it got corrupted, though :P

As I asked in the other thread...

Are there any specific circumstances you know about when it crashed? Certain units being / appearing on screen, certain actions you took? Scrolling to a specific position on the map?

Share this post

Link to post

i played the game before, and i dunno why suddenly it wont work now. I play perfectly, then get the following application error


The instruction at 02cb002b referenced memory at 00000004
The memory could not be read from


Click on OK to terminate the application



I have installed the game outside of program files and within, i have installed the patch fresh and cleanly, applied the default options and tried turning off the odd one, and i get the same error every time, it sometimes happens in mission 1 of GDI, but mostly in 2 and even far more often in 3, i have gotten to mission 3 5 times today and always stopped by that crash. And im starting to think it might be the unofficial patch causing the problems, which sucks cos dayum does it make the game more playable.

I have also ran the game, and even installed the patch as admin and not as admin, and in and out of compatibility mode on my last attempt.


Any help on this? thanks!

Edited by Irishguy

Share this post

Link to post


Sadly, 02cb002b is outside the normal addressing range of the game's program instructions (I added that to the first post now; the range is 00410000-00740000), meaning I can't look inside the program and check what it is actually executing. Usually this means it is an OS level problem rather than a specific internal C&C one.

As the instructions in the first post ask, though... please describe what exactly was happening in the game at the moment it crashed, what system you are playing on, whether you were using cnc-ddraw....

On 4/09/2018 at 8:14 PM, Irishguy said:

i have gotten to mission 3 5 times today and always stopped by that crash

Uh. You know you can use savegames in this game, right? I mean, after a couple of times... I'd have started saving in every mission :P

Share this post

Link to post

Lol it happens so randomly that its all over the place, and if it was only ever mission 3, then i wouldnt care much and id save every 1 min and keep going xD, but sadly, it happens on 1 and 2 as well, tho rare. Im sad to hear its not something your able to effect, but cant be helped. And as to what im doing when it happens, im simply building my base, my units are securing the area around me and pushing the fog of war back to the cliff line south of the nod base. Sometimes i get right to the nod base before a crash, sometimes im still on my side of the cliffs. Its very random.


Oh and yes im using cncdraw, windows 7 64bit, 16gb ram, 4gb graphics card,  intel core i7-4790

Edited by Irishguy

Share this post

Link to post

Hi Nyerguds, recently re-downloaded the full game and patch off your site. Game crashes immediately on launch regardless of settings in CCConfig.

"The instruction at e6327cad referenced memory at e6327cad. The memory cannot be read from".

The game shows to be running but not responding in the task manager.

Yes its not inside the hexadecimal range specified but the only thing that searches up with are random C&C forum pages, none of which specify this error nor any solution. I have tried external tweaks but none seem to help. I was hoping you might have some insight.

Win 10 (Version 1803 / OS Build 17134.407) / i5-3570k / 16gb Ram / 980ti


P.S. Love your work, been playing C&C on and off for years with your patch.


Edit: Also what are your thoughts on the recent C&C Remaster announcement if you have any?


Edit 2: Welp I'm the local idiot, compatibility did need to be on XP SP3 for it to work.


Edited by Kilo11

Share this post

Link to post

Ugh. I really need to fix that default compat mode...



Share this post

Link to post

Similar issue to all the above.  Random crashes that are appearing with more frequency.  Below is an example.


Here is what I can tell you.

1. Lenovo G70 laptop running WIndows 10 on Intel CORE i5 with Windows XP (Service Pack 3) compatibility shortcut setting.  C&C95 V .1 .06c r3.

2. Error instruction and memory location vary by mission and savegame within the mission.  Note, I am playing new fan missions not the standard missions but have played many of these same missions years ago with few errors in the past (except for Devil or the Deep Blue Sea which I could never successfully play to completion).  The error above is from fan mission "The Confluence" (SCG219EA).

3. Problem seems to follow a savegame.  By that I mean, if I load a savegame the exact same error occurs the exact same number of seconds into the savegame load regardless of what in-game actions are taken (e.g. unit/structure builds, attacks, etc.).  I get the impression it has something to do with the AI placing units in the game although there is no way to verify this.

Since the error follows the savegame, I was wondering if there is any way to analyze and edit savegames to detect and correct potential map errors.  Any insight would be helpful.  C&C95 is a fantastic game which I still love to play after all these years.  Props to Nyerguds and the rest of the community!



UPDATE: Looking through earlier posts I see the same instruction related to reinforcing with Chinooks so it is likely a problem with the AI bringing units on the map.  This mission does regularly try to land Chinooks in your base so no doubt this is also why it happens precisely 79 seconds after each reload of my last good save.  I'll try moving around the Mammoths I have protecting the base.

Nope! Neither moving units or selling structures solved the problem.  Guessing it occurs during creation of the Chinooks. Any way to disable the creation? I'm a coder by profession but not familiar with the AI language or syntax used though the snippets I see here look pretty straightforward.  Questions include how to trace error memory location to code line and then how to edit and save.

OK, looks like I can edit the .INI file with Notepad.  I see trigger lines that look like good candidates.  Is there a trigger tutorial anywhere?

fsatk=Time,Create Team,20,BadGuy,fsatk,0
tsatk=Time,Create Team,55,BadGuy,tsatk,1
atk1=Time,Create Team,85,BadGuy,atk1,1

OK, found INI file tutorial.  Potentially problematic Trigger and associated TeamType appear to be


tran2=BadGuy,0,0,0,0,0,7,0,0,0,4,BIKE:3,TRAN:1,E5:2,HELI:2,4,Move:6,Unload:6,Move:5,Attack Base:99,0,0

However, removing these lines did nothing.  Does original INI get copied into savegame thereby rendering changes to INI file useless?  If so, is there a savegame file editor so I can locate and edit triggers?

Edited by Boski

Share this post

Link to post
On 11/01/2019 at 9:04 PM, Boski said:

OK, looks like I can edit the .INI file with Notepad.  I see trigger lines that look like good candidates.  Is there a trigger tutorial anywhere?

Here you go:

The savegames are basically straight memory dumps of the game, though. They can't really be edited.

Share this post

Link to post

When my game crashes, I get no such error msg or code as you state here...only an error msg at startup, named e6327 cad.
Any chance of some info on where to find these error msg you state here? (Yes, im a noob...im sorry) :)

This is also something that only happens when installing the patch, and doing the config run trough (As increasing the resolution and such) but nothing else.
If I try to start up the game without it... it works fine, until the commando mission where top-of-the map happens... tried to install the patch but get some graphical glitching and such (Do you want a screen shot maybe?) 

Hopefully, you understand what I mean :thumbsup:


Edit: This being the same as stated above, Im not really sure there has been any fixes for it or not :) Cause I've tried litteraly everything I could dig up about fixes for it, stated in forums and such (which pointed to alot of YOUR fixes from diffrent places) nothing seems to work properly :(


Edit2: Took a screenshot with what happens ingame with the CCC config, it doesnt do anything else than stretching the window outside the border, but the games window stays the same.... which glitches it for me :(

With CCC config.jpg

Edited by Nongulavu

Share this post

Link to post


That resolution glitch issue is mentioned in the readme. Just press tab to open the sidebar and it'll perform a refresh that stops that glitching.

As for the crash, check if compatibility is enabled on the C&C95 executable. If it is, disable it. Note that CCConfig will re-enable it, because it was made for WinXP where Win95 compat mode worked best.

Share this post

Link to post

This seems like a different issue. That is the GDI commando mission, the map is larger than that.

Share this post

Link to post


No, that's exactly the kind of glitches you get when loading a savegame of the mission that was saved in a lower resolution. I put code into the game to reset the viewport, but it is tied to opening the sidebar, so if the sidebar is not open it is not automatically executed on mission load.

Share this post

Link to post
Posted (edited)


I'm using Linux (Zorin), so I'm not sure if you can help me, and I understand if you can't but thought I'd check with you. If I'm posting on the wrong thread, then I apologize - please direct me where to post this question.

I installed the game with WINE, used the patch at: http://nyerguds.arsaneus-design.com/cnc95upd/cc95p106/

Patch 1.06c revision 3 (29.4MB)

I'm in the first GDI mission and the game freezes before or after I unpack the MCV. Pretty much very  early in the mission. I have stuttering sound once I alt-tab but it has crashed, nonetheless.

I run it on 640x480 and even tried CncDraw disabled. Running in no-cd mode doesn't make a difference.

Thanks for any help.

Update: Trying it in windowed mode helped a bit. Got me through to 2nd mission but then it crashes when I move my troops up to the NOD base. I'm nowhere at the top yet. I have read of this http://nyerguds.arsaneus-design.com/cnc95upd/cc95p106/bugs/bug-topofmap.png and I don't think this is what is happening.

Edited by cmdl

Share this post

Link to post

The top-of-map bug is one of the issues the patch fixes, so it can't happen at all if you use the patch.

Overall, though, no idea on all that; I never tried installing this on Linux.

I believe cncnet has a Linux package, but it might just be a stripped-down package for multiplayer only.

Share this post

Link to post

Ok. Thanks. I'll move on then.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.